PDA

Visualizza la versione completa : [c++ e gtkmm] Errore se passo gli exe ad altri..


Kilin
30-08-2008, 15:51
ciao a tutti...

come da titolo... dopo svariate peripezie finalmente sono riuscito a far funzionare l'ambiente gtkmm su windows xp.. faccio le mie prove, tutto funziona bene.. provo allora a passare alcuni exe che ho generato a degli amici, loro con Windows vista... ed ecco che ottengono questo errore:


IMPOSSIBILE AVVIARE L'APPLICAZIONE SPECIFICATA
LIBGLADEMM-2.4-1.DLL NON STATO TROVATO

questo errore nel caso che l'applicazione che gli passavo caricasse una GUI in un file .glade... se invece un'applicazione con GUI fatta 'a mano', la libreria richiesta libatkmm-1.6-1.dll...

ora: la prima cosa che ho pensato che sia necessario l'ambiente gtk per farli girare...
la seconda cosa che ho pensato subito dopo che ci sono un sacco di programmi che usano le librerie gtk, e non richiedono certo l'istallazione di un ambiente gtk a tutti gli utenti...

sapete dirmi come posso risolvere questa cosa?

vi ringrazio...

menphisx
30-08-2008, 19:54
Richiedono l'ambiente GTK per funzionare ...
Utilizza un'installer ...

:ciauz:

Kilin
30-08-2008, 20:20
uhm uhm... quindi contestualmente alla mia applicazione devo installate gtk.. nel caso di window gtkmm..

sai indicarmi qualcosa di specifico? non ne ho mai utilizzati...

ti ringrazio..

menphisx
30-08-2008, 20:23
Originariamente inviato da Kilin
uhm uhm... quindi contestualmente alla mia applicazione devo installate gtk.. nel caso di window gtkmm..

sai indicarmi qualcosa di specifico? non ne ho mai utilizzati...

ti ringrazio..

Non saprei per windows io lavoro in ambiente linux/unix :fagiano:

Kilin
30-08-2008, 20:40
uhm uhm... quindi contestualmente alla mia applicazione devo installate gtk.. nel caso di window gtkmm..

sai indicarmi qualcosa di specifico? non ne ho mai utilizzati...

ti ringrazio..

Caiodark
31-08-2008, 13:04
Non ho mai distribuito una applicazione in windows con gtk pero' ho installato gimp e devi per forza di cose installare le librerie gtk prima. Avendo usato glade con c++ devi installare anche le librerie del gtkmm.

Le gtk le trovi nel sito di gimp, gtkmm dovresti trovarla nel sito http://www.gtkmm.org/ sicuramente ci sono le versioni per windows.

Loading