PDA

Visualizza la versione completa : schermo che non si riaccende più Ubuntu 7.04


spariggio82
17-09-2008, 19:44
Salve a tutti

Ho un problemino con alcune macchine in ufficio.

Praticamente al mio rientro dalle vacanze ho effettuato l'upgrade dei pacchetti via adept e sembrava andare tutto ok finché non mi sono accorto che dopo 10 min lo schermo si è spento E NON SI RIACCENDE PIÙ.

La cosa strana è che il sistema funziona perfettamente infatti vi accedo via ssh e posso lavorarci tranquillamente solo che non riesco a lavorarci FISICAMENTE perché il display rimane spento e non c'è verso di riaccenderlo in alcun modo.

Anche riavviando il problema si ripropone.

Ho provato a killare e riavviare X e questo è quanto ottengo come output via ssh:

latora@iqc353:~$ sudo startx
xauth: creating new authority file /home/latora/.serverauth.31855



X Window System Version 7.2.0
Release Date: 22 January 2007
X Protocol Version 11, Revision 0, Release 7.2
Build Operating System: Linux Ubuntu
Current Operating System: Linux iqc353 2.6.20-16-server #2 SMP Tue Feb 12 02:16:
56 UTC 2008 x86_64
Build Date: 13 June 2008
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Sep 17 19:30:52 2008
(==) Using config file: "/etc/X11/xorg.conf"

(EE) No devices detected.

Fatal server error:
no screens found
XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.


Qualcuno ha idea di come metterci mano? Grazie in anticipo

francofait
17-09-2008, 19:48
è stato aggiornato il kernel , devi reinstallare i driver della scheda grafica.

Su macchine in produzione gli aggiornamenti si fanno solo in caso di inevitabile necessità e limitatamente ai pacchetti interessati a problemi di sicurezza o bugfix . Continui uporade o dist-upgrade globali su SO che rispondo bene non portano benefici di alcun genere anzi possono risultare un boomerang del tutto gratuito.

spariggio82
26-09-2008, 09:19
è stato aggiornato il kernel , devi reinstallare i driver della scheda grafica.


Mi spiace franco ma il problema non sembra essere questo.

Ho controllato se versione del kernel e quella del driver coincidono ed è così (dove non lo era ho fatto combaciare le due cose). Una volta riavviato il sistema il desktop grafico parte tranquillamente.

Tuttavia il problema sembra non essere li. Infatti dopo circa 10 min mi accorgo che lo schermo rimane "bloccato" come se gli fosse stata scattata una fotografia e dopo 20 min di inattività lo schermo si spegne riportando la macchina a quello stato di inaccessibilità fisica nel quale le ho trovate.

In sostanza punto e a capo. Cos'altro posso "controllare" per cercare di capire dove stia il problema?

Faccio notare che su 4 macchine (identiche sotto tutti i punti di vista) in ufficio 3 presentano il problema ed una no. Non vorrei che sia un problema hardware (purtroppo la stanza è senza climatizzazione e le macchine sono state SEMPRE accese durante tutto questo periodo).

Grazie ancora

bereshit
26-09-2008, 12:00
eh.. no device detected....

prova scambiare le schede grafiche di una che non funzion con l'unica macchina che funziona.. vedi che succede..

spariggio82
26-09-2008, 12:09
purtroppo le macchine sono ancora in garanzia ...

Stavo pensando di usare una qualche applicazione di remote desktop per vedere se riesco ad importare il desktop di quella macchina sulla mia in modo da verificarne il funzionamento. Sto pensando male oppure no?

andy caps
26-09-2008, 12:41
se parte regolarmente e poi fa questo freeze puo' darsi che sia lo standby che crea il problema

prova con il comando

xset -dpms

disabilita la gestione energia dello schermo nella sessione in corso

Loading