PDA

Visualizza la versione completa : nn mi va internet


marte999
20-09-2008, 11:46
ciao a tutti

c' qualcuno che potrebbe darmi una mano a far funzionare internet su ubuntu??? ho gia provato a seguire guide fare parecchie prove ma niente il risultato finale sempre lo stesso.:dh: :dh: :dh:

utilizzo un router della mediacom 7WRAD54 e come scheda di rete ho (SiS 191 1000/100/10 ethernet device)


se c' qualcuno in grado di darmi una mano per favore si faccia avanti perch vorrei passare ad utilizzare soltano ubuntu per senza internet :nonono:

ciao e grazie

detroit
20-09-2008, 12:10
guarda io l'altro giorno ho provato ubuntu desktop,come ho installato mi ha rilevato scheda,si fatto assegnare un ip dal router ed ho navigato tranquillamente.stesso dicasi per ubuntu server.va tutto in automatico.puoi descrivere il tuo problema pi in dettaglio?

marte999
20-09-2008, 12:41
nn riesco a navigare ho gia fatto un po di provo ma niente, inserendo l'indirizzo per entrare nelle opzione del router in firefox nn mi entra(poi domanda stupida io il ruoter l'ho gia configurato in windows anche se riuscissi ad entrare cosa dovrei cambiare?perch le impostazioni che il libretto mi dice di inserire per il mio providere sono gia inserite)anche su un altro forum ho gia chiesto mi hanno fatto inserire dei codici nel terminale sembra che sia tutto a posto per nn va :dh: se sapete cosa dovrei cambiare o qualche info che dovrei darti chiedi, perch sono un principiante con ubuntu.

francofait
20-09-2008, 12:51
Se hai portato a termine l' installazione la connessione deve funzionare per forza , l' installer da live ne fa uso per andarsi a scaricare i pacchetti per la localizzazione della lingua italiana.
Io dico che hai la scheda di rete configurata inattiva al boot nelle opzioni di rete.

marte999
20-09-2008, 13:14
ok per a me con windows va tutto cio io in questo momento sto navigando con le stesse cose.
per attivare la scheda di rete come si fa? scusami ma e da un giorno e mezzo che uso ubuntu e nn sono pratico

ciao e scusami per il disturbo

marte999
20-09-2008, 13:16
o se no potresti darmi qualche codice cosi vedi cosa nn va?
ciao

sacarde
20-09-2008, 14:10
se non ho capito male.... e' il router che si connette al provider

il sistema deve solo, attraverso l'ethernet, chiedere l'ip al dhcp del router


p.s.
il comando manualmente sarebbe:
dhclient eth0 o dhcpcd eth0

e poi sistemare il default gateway: route add default gw 192.168.x.y quello che e'


p.s. p.s.
il device eth0 lo hai ?

marte999
20-09-2008, 14:13
guarda penso di si per nn ne sono sicuro ho fatto mille prove mi hanno dato mille codici da provare sembra che sia tutto a posto, mo provo con il codice che mi hai dato e provo


ciao e grazie

marte999
20-09-2008, 14:25
ho provato a mettere i codici mi hai detto ed uscito cosi ovviamente internet sta ancora andando c' qualcosa di anormale? :D




marco@marco-desktop:~$ dhclient eth0
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

can't create /var/lib/dhcp3/dhclient.leases: Permission denied
Can't create /var/run/dhclient.pid: Permission denied
drop_privileges: could not set group id: Operation not permitted
marco@marco-desktop:~$ sudo dhclient eth0
[sudo] password for marco:
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

Listening on LPF/eth0/00:1e:8c:07:9d:81
Sending on LPF/eth0/00:1e:8c:07:9d:81
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 13
No DHCPOFFERS received.
No working leases in persistent database - sleeping.
marco@marco-desktop:~$ dhcpcd eth0
The program 'dhcpcd' is currently not installed. You can install it by typing:
sudo apt-get install dhcpcd
bash: dhcpcd: command not found

sacarde
20-09-2008, 17:09
l'errore dice che non trova nessun server dhcp in rete

- assicurati che il router lo abbia attivo il dhcp
- controlla che il kernel riconosca la ethernet (prova: dmesg | grep eth0)


se ti puo essere di aiuto leggiti:

http://help.ubuntu-it.org/8.04/ubuntu/internet/it/index.html

Loading