PDA

Visualizza la versione completa : Ubuntu e scheda video


cargil
08-10-2008, 19:46
Salve ho installato Ubuntu e ho una scheda video nVIDIA GeForceGo 6100

Quando avevo windwos installato si vedeva molto meglio, pi a fuoco. Ora con Ubuntu non si vede molto bene... le lettere piccole ad esempio mi risultano sfuocate...
che faccio?
Grazie!
Ciao!

francofait
08-10-2008, 19:58
Originariamente inviato da cargil
Salve ho installato Ubuntu e ho una scheda video nVIDIA GeForceGo 6100

Quando avevo windwos installato si vedeva molto meglio, pi a fuoco. Ora con Ubuntu non si vede molto bene... le lettere piccole ad esempio mi risultano sfuocate...
che faccio?
Grazie!
Ciao!

dal menu di sistema avvi : hardware-driver-manager ti scarica e ti installa in automatico i driver direttamente dal sito di nvidia.
Ovviamente la connessione internet deve funzionare

cargil
08-10-2008, 20:15
dal menu di sistema non trovo hardware-driver-manager, ma restricted drivers manager.
Entro e mi dice che nvidia enabled
e basta... boh!

francofait
08-10-2008, 20:49
Originariamente inviato da cargil
dal menu di sistema non trovo hardware-driver-manager, ma restricted drivers manager.
Entro e mi dice che nvidia enabled
e basta... boh!

controlla il file fi configurazione /etc/x11/xorg.conf nella sezione:

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Con instalati i driver di nvidia la variabile Driver come sopra , se invece c' solo il driver standard

Driver "nv"

Nel qual caso vai in nvidia.com e scarichi il driver .run , lo metti in una directory utente di comodo e dai al file
i permessi di esecuzione:sudo chmod 777 /percorso/*.run

riavvi da opzione single user , senza X e vai a lanciare il pacchetto dei driver .
i sorgenti e l' header del kernel li hai gi installati per cui l' installazione procede da se , devi solo confermare tutte le richieste , poi a driver installato riavvii questa volta regolarmente.

cargil
08-10-2008, 21:09
hai scritto:

Con instalati i driver di nvidia la variabile Driver come sopra , se invece c' solo il driver standard

Driver "nv"

Io ho controllato nella sezione device. Ma non capisco. Ti riporto quanto vedo:


Section "Device"
Identifier "nVidia Corporation MCP51 PCI-X GeForce Go 6100"
Driver "nvidia"
Busid "PCI:0:5:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

cosa vuol dire "variabile driver"?

Grazie mille

francofait
08-10-2008, 22:06
Originariamente inviato da cargil
hai scritto:

Con instalati i driver di nvidia la variabile Driver come sopra , se invece c' solo il driver standard

Driver "nv"

Io ho controllato nella sezione device. Ma non capisco. Ti riporto quanto vedo:


Section "Device"
Identifier "nVidia Corporation MCP51 PCI-X GeForce Go 6100"
Driver "nvidia"
Busid "PCI:0:5:0"
Option "AddARGBVisuals" "True"
Option "AddARGBGLXVisuals" "True"
Option "NoLogo" "True"
EndSection

cosa vuol dire "variabile driver"?

Grazie mille

da quel che vedi c' 'nvidia' quindi il driver di nvidia installato ed attivo.
rimane da vedere se xorg configurato per la miglior risoluzione possibile con il tuo monitor .
Uso anche io una nvidia come scheda video , configurato a puntino xorg almeno a me va meglio in linux che in xp su tutte 4 le distribuzioni installate.

cargil
09-10-2008, 11:12
Quindi devo andare a vedere in Xorg.
Come faccio a capire se sto usando la massima risoluzione?
Grazie e ciao!

cargil
09-10-2008, 15:26
Francofait, problema risolto...
bastava andare in terminale e scrivere:

sudo nvidia-settings e aumentare la risoluzione

Ciao

cargil
10-10-2008, 14:28
Ragazzi! Ciao!
In precedenza avevo scritto di aver risolto il problema in oggetto. Solo parzialmente per..
Infatti devo sempre all'avvio di ubuntu andare nel terminale e fare la procedura di settaggio, aumentando la risoluzione... fino a 1280. Io clicco sempre su applica, ma al riavvio del sistema mi torna la risoluzione a 1024!
Uffa devo stare ogni volta l a cambiarla?

Questo il messaggio che mi esce dal terminale! Mi aiutate!? Please!!! Grazie!


carlo@carlo-laptop:~$ sudo nvidia-settings
Password:

ERROR: Unable to determine valid vertical refresh ranges for display device
'AUO' (GPU: GeForce Go 6100)!


ERROR: Failed to add display device 'AUO' to screen 0!


ERROR: Failed to add X screen 0 to X config.


ERROR: Failed to add X screens to X config.


ERROR: Failed to generate an X config file!

francofait
10-10-2008, 14:50
Originariamente inviato da cargil
Ragazzi! Ciao!
In precedenza avevo scritto di aver risolto il problema in oggetto. Solo parzialmente per..
Infatti devo sempre all'avvio di ubuntu andare nel terminale e fare la procedura di settaggio, aumentando la risoluzione... fino a 1280. Io clicco sempre su applica, ma al riavvio del sistema mi torna la risoluzione a 1024!
Uffa devo stare ogni volta l a cambiarla?

Questo il messaggio che mi esce dal terminale! Mi aiutate!? Please!!! Grazie!


carlo@carlo-laptop:~$ sudo nvidia-settings
Password:

ERROR: Unable to determine valid vertical refresh ranges for display device
'AUO' (GPU: GeForce Go 6100)!


ERROR: Failed to add display device 'AUO' to screen 0!


ERROR: Failed to add X screen 0 to X config.


ERROR: Failed to add X screens to X config.


ERROR: Failed to generate an X config file!

Intervieni a manina direttamente su /etc/x11/xorg.conf nella sezione relativa alle risoluzioni disponibili (subsection display), elimini tutte quelle che non ti servono e lasci solo quella che serve a te.

Loading