PDA

Visualizza la versione completa : OpenSuse11 e macchina virtuale per XP


MaPPaZZo
17-10-2008, 01:52
Ciao a tutti.

ho installato openSUSE 11 e configurato compiz e va tutto a meraviglia!

adesso il problema :

su un altro disco ho win xp. ho installato virtualbox, ma da quanto ho capito mi consente di usare XP solo dopo aver effettuato una nuova installazione nella partizione "virtuale" che mi obbliga a fare.

Ho installato poi lo strumento XEN integrato, ma quando lo apro mi dice che non avviato il servizio. Allora riavvio e al boot seleziono di far partire lui invece che caricare opensuse "normale".

solo che mi va in modalit testo e nn ci capisco piu di tanto....

ora la domanda : posso accedere all'installazione di xp che ho gi senza doverlo installare di nuovo?? come?

grazie mille a tutti! ;-)

MaPPaZZo
17-10-2008, 02:56
Questo l'eroore che mi restituisce quando cerco di configurare la macchina virtual tramire XEN.


Unable to open connection to hypervisor URI 'xen:///':
<class 'libvirt.libvirtError'> virConnectOpenReadOnly() failed
Traceback (most recent call last):
File "/usr/share/virt-manager/virtManager/connection.py", line 325, in _open_thread
self.vmm = libvirt.openReadOnly(self.uri)
File "/usr/lib64/python2.5/site-packages/libvirt.py", line 144, in openReadOnly
if ret is None:raise libvirtError('virConnectOpenReadOnly() failed')
libvirtError: virConnectOpenReadOnly() failed

MaPPaZZo
17-10-2008, 09:20
aggiornamento:

virtualbox inteso come "virtualbox OSE":


ho provato a installare xp da virtualbox, giusto per vedere cosa succedeva, ma mi dice che il kernel non caricato.


VirtualBox kernel driver not installed. The vboxdrv kernel module was either not loaded or /dev/vboxdrv was not created for some reason. Re-setup the kernel module by executing '/etc/init.d/vboxdrv setup' as root.
VBox status code: -1908 (VERR_VM_DRIVER_NOT_INSTALLED).


Codice&nbspd'uscita:
0x80004005
Componente:
Console
Interfaccia:
IConsole {1dea5c4b-0753-4193-b909-22330f64ec45}



Ho aperto la configurazione dei servizi di sistema di yast e in effetti il modulo del kernel "VBOXDRV" lo da come non avviato, se lo abilito mi ristituisce un errore "non meglio specificato".

/etc/init.d/vboxdrv start ha restituito 1 (Errore non meglio specificato)


che faccio?

:dh:

Loading