PDA

Visualizza la versione completa : Problema con i permessi


paolo t
25-10-2008, 22:25
Con utente "root", vario i permessi di una directory ( la partizione di win), abilitando in scrittura l'utente "normale".
Sia da console con chmod, che da konqueror, la "variazione" non permamente, nel senso che quando riavvio l'utente "normale" non ha pi permessi per scrivere su tale partizione. Forse devo fare la varizione ad un altro livello?

:dh:

detroit
25-10-2008, 23:22
ma la partizione la rimonti ad ogni riavvio?

francofait
26-10-2008, 00:15
Originariamente inviato da detroit
ma la partizione la rimonti ad ogni riavvio?

l' accesso alle partizioni nel SO definito fal file di configurazione /etc/fstab

detroit
26-10-2008, 00:29
Originariamente inviato da francofait
l' accesso alle partizioni nel SO definito fal file di configurazione /etc/fstab

lo so.visto che diceva la partizione di win,presumo non la monti al boot

paolo t
26-10-2008, 07:41
Originariamente inviato da detroit
ma la partizione la rimonti ad ogni riavvio?

S, ho questa riga in fstab:
/dev/sda3 /mnt/sda3 vfat,ext3,ext2,reiserfs auto,users,exec 0 0 (partizione win di "dati")
cos come la sda1 (partizione win del s.o.) che invece ha tutti i permessi in scrittura

francofait
26-10-2008, 08:32
/dev/sda3 /mnt/sda3 vfat,ext3,ext2,reiserfs auto,users,exec 0 0

simplymepis

/dev/sda3 /mnt/sda3 vfat auto,user,exec,owner,umask=000,rw 0 0

se la partiz formattata ntfs , chiaramente non puoi usare vfat , devi nspecifiare ntfs-3g,fuse

inoltre devi togliere l' entry comment del dispositovo autoupdate fstab altrimenti al riavvio viene sovrascritto e riportato allo sato iniziale

da windows inoltre esegui anche l' windefrag della partizione.

francofait
26-10-2008, 09:47
Originariamente inviato da francofait
/dev/sda3 /mnt/sda3 vfat,ext3,ext2,reiserfs auto,users,exec 0 0

simplymepis

/dev/sda3 /mnt/sda3 vfat auto,user,exec,owner,umask=000,rw 0 0

se la partiz formattata ntfs , chiaramente non puoi usare vfat , devi nspecifiare ntfs-3g,fuse

inoltre devi togliere l' entry comment del dispositovo autoupdate fstab altrimenti al riavvio viene sovrascritto e riportato allo sato iniziale

da windows inoltre esegui anche l' windefrag della partizione.

/dev/sdb5 / ext3 defaults,noatime 1 1
/dev/sdb1 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
devpts /dev/pts devpts mode=0622 0 0
sysfs /sys sysfs defaults 0 0
# Dynamic entries below ##### questa la riga da eliminare, non semplice commento, punto di entry per fstab autoupdate ##
/dev/sdb6 /mnt/sdb6 auto noauto,users,exec 0 0
/dev/sdc1 /mnt/sdc1 auto noauto,users,exec 0 0
/dev/sdc5 /mnt/sdc5 auto noauto,users,exec 0 0
/dev/sdc6 swap swap sw,pri=1 0 0
/dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
/dev/scd0 /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0


################################################## ##################

aggiornato cosi:


dev/sdb5 / ext3 defaults,noatime 1 1
/dev/sdb1 swap swap sw,pri=1 0 0
proc /proc proc defaults 0 0
usbfs /proc/bus/usb usbfs devmode=0666 0 0
devpts /dev/pts devpts mode=0622 0 0
sysfs /sys sysfs defaults 0 0
/dev/sdb6 /mnt/sdb6 auto noauto,users,exec 0 0
/dev/sdc1 /mnt/sdc1 auto noauto,users,exec 0 0
/dev/sdc5 /mnt/sdc5 auto noauto,users,exec 0 0
/dev/sdc6 swap swap sw,pri=1 0 0
/dev/sda1 /mnt/winxp ntfs-3g,fuse user,owner,exec,auto,umask=000,rw 0 0
/dev/scd0 /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0

Ovviamente questo l' fstab mio , quindi per te solo come riferimento.

paolo t
26-10-2008, 16:39
[QUOTE]Originariamente inviato da francofait
...
se la partiz formattata ntfs , chiaramente non puoi usare vfat , devi nspecifiare ntfs-3g,fuse

inoltre devi togliere l' entry comment del dispositovo autoupdate fstab altrimenti al riavvio viene sovrascritto e riportato allo sato iniziale
...

Ok Franco, il discorso dell'ntfs lo avevo gi "aggiustato" col prezioso ntfs-3g, da te suggeritomi in altro post.
Per il resto, io l'"entry comment" ce l'ho inseiro dopo le partizioni...

Al momento la mia fstab e' la seguente:

# Pluggable devices are handled by uDev, they are not in fstab
/dev/sda6 / auto defaults,noatime 1 1
none /proc proc defaults 0 0
none /proc/bus/usb usbfs devmode=0666 0 0
none /dev/pts devpts mode=0622 0 0
none /sys sysfs defaults 0 0
/dev/sda1 /mnt/sda1 ntfs-3g auto,users,exec 0 0
/dev/sda3 /mnt/sda3 vfat,ext3,ext2,reiserfs auto,users,exec 0 0
/dev/sda5 swap swap sw,pri=1 0 0
# Dynamic entries below
/dev/cdrom /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0
/dev/scd0 /media/cdrom udf,iso9660 noauto,users,exec,ro 0 0

dove sda1 e' appunto la ntfs, e sda3 la partizione dati dove non riesco a rendere definitive le modifiche dei permessi.
Ora ci rimetter mano tra una decina di giorni, comunque sempre... grazie a tutti.

;)

paolo t
15-11-2008, 17:21
Scusate, torno sull'argomento; non datemi del... "testardo".
Il problema ora circoscritto a questo, riferendomi alla fstab del precedente post : riesco a "scrivere" su sda1, ma non su sda3 (che una fat32).

:dh:

paolo t
22-11-2008, 16:13
sempre fermo .... sul problema

Loading