PDA

Visualizza la versione completa : Rotella del mouse che non funziona


RokStar
30-10-2008, 14:05
Salve,

non riesco a far funzionare la rotella del mouse, con evidente dispiacere da parte mia.
Questo quanto si evince da dmesg | grep USB


[ 2.175515] usb usb8: Product: EHCI Host Controller
[ 2.175518] usb usb8: Manufacturer: Linux 2.6.26-1-686 ehci_hcd
[ 2.175521] usb usb8: SerialNumber: 0000:00:1d.7
[ 2.435863] usb 3-1: new low speed USB device using uhci_hcd and address 2
[ 2.619912] usb 3-1: configuration #1 chosen from 1 choice
[ 2.640410] usb 3-1: New USB device found, idVendor=15ca, idProduct=00c3
[ 2.640410] usb 3-1: New USB device strings: Mfr=0, Product=2, SerialNumber=0
[ 2.640410] usb 3-1: Product: USB Optical Mouse
[ 2.899813] usbcore: registered new interface driver hiddev
[ 2.940599] input,hidraw0: USB HID v1.10 Mouse [USB Optical Mouse] on usb-000

Questo quanto attualmente in /etc/X11/xorg.conf:


Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection


Cosa fare? Potrebbe essere colpa del tipo di mouse (usb 2.0 - marca Techmade)?

Saluti

francofait
30-10-2008, 14:20
no la configurazione a azzo , se in usb noon pu essere psaux il driver

francofait
30-10-2008, 14:22
Originariamente inviato da francofait
no la configurazione a azzo , se in usb noon pu essere psaux il driver

Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection

lion1810
30-10-2008, 14:26
era da tanto che leggevo di sto broblema :stordita: :stordita:

comunque

l'opizone che l'attiva giusta ed questa.
Option "Protocol" "IMPS/2"

:fagiano:

prova ad abilitare il


Option "Emulate3Buttons" "yes"

francofait
30-10-2008, 18:39
Originariamente inviato da lion1810
era da tanto che leggevo di sto broblema :stordita: :stordita:

comunque

l'opizone che l'attiva giusta ed questa.
Option "Protocol" "IMPS/2"

:fagiano:

prova ad abilitare il


Option "Emulate3Buttons" "yes"


il device che sbagliato ,l' usb richiede /input/ mice

RokStar
30-10-2008, 21:12
Ancora non va. /var/log/Xorg.0.log:



(**) Option "Protocol" "IMPS/2"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "IMPS/2"
(**) Option "CorePointer"
(**) Mouse0: always reports core events
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "5"
(**) Option "Emulate3Buttons" "yes"
(**) Mouse0: Emulate3Buttons, Emulate3Timeout: 50
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 9
(**) Mouse0: Sensitivity: 1
(II) evaluating device (Keyboard0)
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) evaluating device (Mouse0)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(II) Mouse0: ps2EnableDataReporting: succeeded

Boh....

lion1810
31-10-2008, 08:30
scusa che distro hai?

RokStar
31-10-2008, 09:14
Originariamente inviato da lion1810
scusa che distro hai?
Debian sid, installata da due giorni utilizzando la netinst testing rilasciata il 28/10/2008. Ha configurato tutto da sola in fase di installazione, funziona tutto tranne la rotella del mouse.
Oggi provo il mouse su un altro pc, facendo partire una live. Se dovesse funzionare la rotella vedr di capire quali moduli vengono caricati e come configurato xorg. :bh:

Ah, se dovesse servire, la mother board una Asus P5K SE.

RokStar
31-10-2008, 10:57
Ok, ho portato il mouse a lavoro, attaccato al pc con XP, e... la rotella non funziona!
:mame:

Ho attaccato un altro mouse usb al pc di lavoro... e la rotella funziona!

Oggi pomeriggio torno dove ho preso il mouse, lo cambio, gli faccio aprire tutti i mouse che hanno e li provo uno a uno finch non ce ne uno con la rotella funzionante. :dh:

lion1810
31-10-2008, 11:41
un bel

dpkg-reconfigure xserver-xorg

per impostare mouse e tastiera

Loading