PDA

Visualizza la versione completa : Linux e connessione internet


birraebirra
05-11-2008, 16:14
ciao a tutti ragazzi.
sono un utente moolto inesperto di linux e per iniziare ho scelto Ubuntu 8.04.1 (consiglio di un'amico). mi piace l'interfaccia e tutto, pure veloce MA:

non riesco a configurare la connessione a internet.
Ho un router Alice gate 2 plus 0.9.5.4 e non riesco a farlo funzionare ne con il wireless ne con l'usb.
Ho anche un Alice modem normale, piccolino e non riesco nemmeno con quello.

Preferirei di gran lunga far funzionare il wi-fi di Alice gate 2 plus.

se qualcuno pu aiutrmi e spiegarmi come si fa lo ringrazio davvero.

Thomas.

livellozero
05-11-2008, 16:32
Assicurati, prima di tutto che la tua scheda sia riconosciuta dal sistema, digitando in un terminale:

sudo iwconfig
e

sudo iwlist scan
e

sudo ifconfig
e controllando che la scheda appaia nell'output (magari posta il risultato)
Se la scheda rilevata e funzionante sei gi a buon punto, dovresti in pratica aprire il networkmanager ed immettere la password per il collegamento.

birraebirra
05-11-2008, 18:55
grazie della risposta.
Pultroppo mi pare di aver capito che la mia scheda wireless non compatibile con ubuntu, ma non sono sicuro, ecco il tutto:

SUDO IWCONFIG
tom@tom-desktop:~$ sudo iwconfig
[sudo] password for tom:
Sorry, try again.
[sudo] password for tom:
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:13 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/70 Signal level=-89 dBm Noise level=-89 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

SUDO IWLIST SCAN
tom@tom-desktop:~$ sudo iwconfig
[sudo] password for tom:
Sorry, try again.
[sudo] password for tom:
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11g ESSID:"" Nickname:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:13 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality=0/70 Signal level=-89 dBm Noise level=-89 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

SUDO IFCONFIG
tom@tom-desktop:~$ sudo ifconfig
ath0 Link encap:Ethernet HWaddr 00:16:e3:a4:59:07
inet6 addr: fe80::216:e3ff:fea4:5907/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

eth0 Link encap:Ethernet HWaddr 00:1d:92:0b:2a:85
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:21 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:3440 errors:0 dropped:0 overruns:0 frame:0
TX packets:3440 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:172000 (167.9 KB) TX bytes:172000 (167.9 KB)

wifi0 Link encap:UNSPEC HWaddr 00-16-E3-A4-59-07-00-00-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:34 errors:0 dropped:0 overruns:0 frame:1
TX packets:247 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:3570 (3.4 KB) TX bytes:11362 (11.0 KB)
Interrupt:22

qualche idea? grazie ancora.

livellozero
05-11-2008, 20:15
probabilmente una scheda atheros e non tutte sono supportate nativamente dai moduli del kernel.
Vedi se ti vengono proposti aggiornamenti del kernel, e nel caso, procedi con tali aggiornamenti. Se sei fortunato, potrebbe bastare per il riconoscimento della scheda.
Per il modello della tua scheda, digita:
dmesg | grep Net

birraebirra
05-11-2008, 20:45
una scheda aheros AR5004X,
pultroppo non posso avere degli aggiornamenti (anche se me ne segna due importanti presumo della scheda) perch non ho modo di connettermi, nemmeno via usb.

pertanto ho saputo di un madwifi, che contiene un serie di aggiornamenti (ho letto nel sito ufficiale anche della mia ar5004x) solo che sono abituato in windows io, e quando vado in ubutu e apro il madwifi non c nessun installer :nonono: :nonono:

scusate ma la prima volta che uso linux :)

Loading