PDA

Visualizza la versione completa : driver ati su ubuntu


RDN_ROXAS
05-11-2008, 20:34
Ciao a tutti Ho ubuntu 8.10. Devo installare i driver della mia scheda grafica ati e perciò ho scaricato il file "ati-driver-installer-8-10-x86.x86_64.run". Quando avvio questo file dal terminale mi dà un errore:

antonio@ubuntu:~$ sh ati-driver-installer-8-10-x86.x86_64.run
Created directory fglrx-install.fD5551
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.542............................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. .................................................. ................
==================================================
ATI Technologies Linux Driver Installer/Packager
==================================================

Error: ./default_policy.sh does not support version
default:v2:i686:lib::none:2.6.27-7-generic; make sure that the version is being
correctly set by --iscurrentdistro

Removing temporary directory: fglrx-install.fD5551
antonio@ubuntu:~$

Non riesco a installare i driver per favore aiutatemi :(
GRAZIE :)

bereshit
05-11-2008, 22:03
ubuntu gli installa di default quelli proprietari se richiesti.. vai in amministrazione sezione driver

RDN_ROXAS
05-11-2008, 22:24
la finestra mi dice:
Nessun driver proprietario è in uso su questo sistema
Per favore aiutatemi, devo assolutamente installare i driver della scheda grafica :(

bereshit
06-11-2008, 00:06
secondo te cosa può voler dire?

controlla se i driver del sito dell'ati sono più aggiornati rispetto a quelli rilasciati con ubuntu.. nel caso controllach esupportino la tua scheda

cmq perchè ti sono tanto necessari i driver ??

magari hai già l'accelerazione abilitata con i driver liberi e manco lo sai..

i driver su liux non funzionana come su windows a meno che siano closed .. non bisogna installare nulla

RDN_ROXAS
06-11-2008, 10:32
Sono fissato con la grafca del pc. Mi sono necessari i driver per abilitare gli effetti grafici di ubuntu. Quando clicco su "effetti aggiuntivi", appare una schermata con scritto "ricerca dei driver" o qualcosa del genere (non ho ubuntu sotto mano adesso). quando la schermata scompare, ne appare un'altra che dice "impossibile abilitare effetti aggiuntivi". Anche a un mio amico faceva questo fino a quando non ha installato i driver per linux della sua scheda grafica distribuiti dal sito della nvidia. Allora io ho scaricato i driver ati per linux distribuiti nel sito stesso dell'ati. il file scaricato è un file .run, lo avvio col terminale e poi mi dà l'errore.

nifriz
06-11-2008, 10:35
Essendo un ATI facilitati il lavoro...

sudo apt-get install envyng*

poi lanci ENVYNG e li lasci installare in automatico i driver.

:ciauz:

RDN_ROXAS
06-11-2008, 11:04
Purtroppo envyng mio dice "non compatibile" !!
C'è un alternativa? Per esempio io ho dovuto utilizzare i driver di windows con ndiswrapper per far funzionare la chiavetta wireless. C'è un programma che può utilizzare i driver di windows anche per le schede grafiche?

nifriz
06-11-2008, 11:56
Non credo esista...
Sei sicuro di avere una scheda Grafica ATI?

RDN_ROXAS
06-11-2008, 12:39
Si, la scheda l'ho montata io. E' una Creative Ati radeon 9200 series AGP TV 128mb

RDN_ROXAS
06-11-2008, 15:54
Ho scoperto che il file "ati-driver-installer-8-10-x86.x86_64.run" non si installava perchè non compatibile con la versione corrente di Xorg. E' possibile in ubuntu installare Xorg 7.3 quindi installare una versione meno recente di quella già installata? Così i driver dovrebbero installarsi.

Loading