PDA

Visualizza la versione completa : openvpn e user/pass con pam


ratal
10-11-2008, 16:14
ciao a tutti ho installato e configurato una vpn.la mia necessita ora e' quella di inserire degli username con relative password da assegnare ai vari clients.ho letto ma in testa ho solo confusione.
fra le ipotesi nell'howto ho prediletto quella via pam tramite il plug-in openvpn-auth-pam.so quindi tutto quello che ho fatto e' stato compilare lo script e posizionarlo in etc/openvpn/
quando vado ad inserire user e password nel client mi viene restituito questo log (allego la parte dove a mio avviso risiede il problema)

AUTH-PAM: BACKGROUND: received command code: 0
AUTH-PAM: BACKGROUND: USER/PASS: ****/**** (username e password da me digitate)
AUTH-PAM: BACKGROUND: my_conv[0] query='Password: ' style=1
AUTH-PAM: BACKGROUND: user 'root' failed to authenticate: Error in service module
Mon Nov 10 16:04:37 2008 us=765855 192.84.144.30:1505 14 variation(s) on previous 10 message(s) suppressed by --mute
Mon Nov 10 16:04:37 2008 us=765885 192.84.144.30:1505 PLUGIN_CALL: POST /etc/openvpn/openvpn-auth-pam.so/PLUGIN_AUTH_USER_PASS_VERIFY status=1
Mon Nov 10 16:04:37 2008 us=765897 192.84.144.30:1505 PLUGIN_CALL: plugin function PLUGIN_AUTH_USER_PASS_VERIFY failed with status 1: /etc/openvpn/openvpn-auth-pam.so
Mon Nov 10 16:04:37 2008 us=765919 192.84.144.30:1505 TLS Auth Error: Auth Username/Password verification failed for peer

allego conf del server

dev tap
lport 5002
mode server
tls-server
proto tcp-server
ifconfig 10.0.1.1 255.255.255.0
ifconfig-pool 10.0.1.50 10.0.1.90
plugin /etc/openvpn/openvpn-auth-pam.so login
ca /etc/openvpn/ca.crt
cert /etc/openvpn/server.crt
key /etc/openvpn/server.key # This file should be kept secret
dh /etc/openvpn/dh1024.pem
max-clients 100
ping 10
verb 7
mute 10
persist-key

che prove mi consigliate di fare?ma soprattutto...DOVE DEVO ANDARE A CREARE I MIEI USER E LE MIE PASSWORD perche' propio nn ho capito...(avevo provato a creare un gruppo chimatao vpn con un utente ma nn entrava dando lo stesso errore)
grazie mille spero possiate darmi una risposta perche' e' un lavoro che devo assolutamente completare :(

ratal
11-11-2008, 09:52
nessuno che riesca almeno ad incanalarmi sulla strada giusta? :(

ratal
11-11-2008, 13:16
forse ho scovato il problema:per un non so quale motivo il mio pc una volta loggato in root nn riesce a passare agli altri utenti:
se da console faccio un su utentecreato si blocca,resta fermo alcuni minuti,e poi torna alla linea di comando root senza restituire alcun messaggio.se invece vado tramite shell ctrl+alt+f6 nn riesco ad accedere e appare un messaggio velocissimo e illeggibile.gli utenti li creo normalmente nel piu' classico dei modi quindi nn sta in questo l'errore.cosa potrebbe essere?

ratal
12-11-2008, 11:43
ora funziona tutto...era semplicemente andato in tilt il pam.formattando ho risolto :)

ratal
12-11-2008, 14:00
ciao ragazzi,sempre riguardo a openvpn,a connessione avvenuto fra i vari clients e il server ho notato che i client perdono la loro connessione ad internet:appena apro il tunnel virtuale non riesco più a navigare con firefox o explorer.è normale questo?
ho abilitato l'ip forward e il nat sul server infatti riesco a pingare tutti gli indirizzi ip anche tramite vpn.perchè nn riesco a navigare secondo voi?ho già provato a fare un push dei dns coi quali si connette il server principale...

|host remoto|---|server openvpn|--INTERNET---<client1,client2 ecc


appena i client 1 e 2 instaurano una vpn col server nn sono più in grado di navigare con mozzilla o explorer,però da console pingano tutti gli ip...mha

Loading