PDA

Visualizza la versione completa : Problema driver scheda video-risoluzione 800x600


cinqui
19-11-2008, 19:37
Ciao a tutti, vi chiedo aiuto perchŔ oggi ho fatto danni su danni (premessa: sono nuovo di linux).

succo della storia: ho smanettato coi driver della scheda video e ora posso tenere solo la risoluzione 800x600...

storia: inizia tutto perchŔ compiz mi dava problemi con la nvidia GeForce 7300 del mio portatile: un problema abbastanza comune, quello della barra con x minimizza ecc che andava a nascondersi sotto la barra superiore di linux. leggo sul web e dicono che Ŕ un problema di incompatibilitÓ tra compiz e i driver della nvidia, mi pare xconfig o una cosa simile.
Preso da una risposta ad una domanda pari alla mia inizio a installare mi pare il gx, o l'xorg... fatto sta che nella mia incompetenza, preso dall'agitazione, inizio a installare tutto ci˛ che si chiama nvidia (ok lo so, sono un pollo) finchŔ, ad un riavvio, Ubuntu decide di farmi partire in modalitÓ low-quality dicendomi che c'Ŕ qualcosa che non va.
Parto d'ansia e lancio in recovery, per altro senza sapere cosa sia, e faccio ancora piu casini. Fatto sta che alla fine della giornata riesco a disinstallare un po di roba, a installarne altra e finalmente Ubuntu sembra ripartire (ah versione 8.0.4) solamente che mi mette in risoluzione 800x600 e non c'Ŕ modo di fargliela levare...

sapete aiutarmi?
Grazie

Enrico

andy caps
19-11-2008, 20:33
prova semplicemente a dare il ccomando nvidia-xconfig

ti dovrebbe rigenerare xorg.conf con le giuste risoluzioni

altrimenti guarda nel pannello delle configurazioni di sistema

c'Ŕ l'apposita utiliti per i driver proprietari. tipo nvidia, per abilitare l'accelerazione 3d

cinqui
19-11-2008, 23:28
ho lanciato il comando che mi hai detto ma mi da questo errore :

Using X configuration file: "/etc/X11/xorg.conf".

VALIDATION ERROR: Data incomplete in file /etc/X11/xorg.conf.
Device section "Configured Video Device" must have a Driver
line.

Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'


mi sa che manca un driver... dopo questo errore ho guardato su risoluzione schermo ma nn Ŕ cambiato nulla... aiuto non riesco a stare con la 800x600 :(

aggiungo: se apro NVIDIA X Server SEttings mi da errore e mi dice di lanciare quel comando qu isopra che pero' mi da errore a sua volta..


riaggiungo : l'ho riprovato ora mi da solo questo

Using X configuration file: "/etc/X11/xorg.conf".
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

aggiungo ancora: ho provato con un metodo trovato in rete ovvero di fare

gksudo displayconfig-gtk

ho provato a cambiare da li lo schermo mettendolo come il mio ovvero 1024x800 e mettere come scheda video nVidia ma fa solo casino...

andy caps
20-11-2008, 00:02
adesso magari riavviando il server x dovresti andare a posto

puoi aanche riavviare del tutto

prima di riavviare controlla di avere i driver instalati
lsmod deve elencare nvidia
sudo modprobe nvidia al limite lo carica
installa synaptic e controlla anche che versione di driver nvidia hai installato
ci sono varie versioni

cinqui
20-11-2008, 00:06
allora il primo comando l'ho fatto, non lista nvidia

il secondo lanciato ma mi da

FATAL: Error running install command for nvidia

syna ce l'ho installato ma ci sono un botto di nvidia.. non so quali devo installare...

attualmente installati ho

nvidia-glx-new

nvidia-settings

xorg

questi quelli installati nella lista di tutti quelli che si chiamano nvidia

gia che ci sono edito e ti aggiorno:
se vado su driver hardware non ho nessun prorietary driver, mentre l'amico mio che ha anche lui nvidia ha i suoi driver li..

andy caps
20-11-2008, 10:28
prova ad installare il pacchetto linux-restricted-modules che dovrebe installare anche i driver nvidia insieme a ubuntu-restricted-extras e envyng-gtk che una volta avviato dovrebe installare e configurare da se i driver

restricted-manager ,per abilitare i driver la nuova ubuntu, sembra non averlo

cinqui
20-11-2008, 17:25
ciao guarda ieri notte alla fine ho instllarei driver di nvidia con envy e ora posso cambiare risoluzione. Il problema Ŕ che anche con sudo nvidia-settings se cambio risoluzione e salvo il file xorg.conf, al riavvio la risoluzione torna a essere 800x600...

mi han detto che a questo punto il problema Ŕ tornato ad essere abbastanza comune e che basterebbe scrivere una cosa nell'xorg... sai cosa?

Grazie x l'aiuto

andy caps
20-11-2008, 18:14
dovresti semmai incollare la sezione del monitor di /etc/X11/xorg.conf oppure settarlo da configurazione sistema

cinqui
20-11-2008, 18:16
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@vernadsky) Thu Jun 5 09:26:53 UTC 2008

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Synaptics Touchpad"
EndSection

Section "Module"
Load "glx"
Load "v4l"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
Option "XkbOptions" "lv3:ralt_switch"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
VendorName "Generic LCD Display"
ModelName "LCD Panel 1280x800"
HorizSync 31.0 - 50.0
VertRefresh 56.0 - 65.0
Gamma 1
ModeLine "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
ModeLine "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
ModeLine "1280x768@60" 80.0 1280 1344 1480 1680 768 769 772 795 -hsync +vsync
ModeLine "1280x720@60" 74.0 1280 1336 1472 1664 720 721 724 746 -hsync +vsync
ModeLine "1280x800@60" 83.0 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug 'n' Play"
ModelName "Plug 'n' Play"
Gamma 1
ModeLine "640x480@60" 25.0 640 656 752 800 480 490 492 525 -hsync -vsync
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "LPL"
HorizSync 30.0 - 75.0
VertRefresh 60.0
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 0
EndSection

Section "Device"
Identifier "device1"
Driver "nvidia"
BoardName "vesa"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce Go 7300"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Virtual 1280 800
Depth 24
Modes "1280x800@60" "1280x720@60" "1280x768@60" "800x600@60" "800x600@56"
EndSubSection
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultDepth 24
Option "AddARGBGLXVisuals" "True"
SubSection "Display"
Depth 24
Modes "640x480@60"
EndSubSection
EndSection

Section "Screen"

# Removed Option "metamodes" "1280x800 +0+0; 800x600@60 +0+0"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
Option "NoLogo" "True"
Option "TwinView" "0"
Option "metamodes" "1280x800 +0+0"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

riesci a capire che devo fare ? :(

andy caps
20-11-2008, 18:23
sembra tutto in regola
1280x800@ dovrebbe essere la risoluzione del monitor prova ad avviare da terminale
krandrtray

poi dall 'icona regolare la giusta risoluzione se lo permette
prova comunque da sistema e magari quando sei sulla giusta risoluzione dare di nuovo nvidia-xconfig

Loading