PDA

Visualizza la versione completa : timeout su webmin


fleone
28-11-2008, 17:52
Salve a tutti, ho acquistato un Virtual Server da Aruba, siccome il plesk che hanno installato loro non funge e mi sono rotto di contattarli, ho installato webmin tramite yum. L'installazione è tutta ok. Il problema è che quando mi collego mi va in timeout. Ho provato a cambiargli porta, da 10000 a 10200, tanto per capire se ci fossero problemi.. ma ... niente, non va. Ho provato anche a disattivarlo e riattivarlo.

Grazie a chiunque mi dia un suggerimento.

sacarde
29-11-2008, 13:47
ma vedi se e' attivo sulla porta?


netstat -an | grep <porta>

fleone
29-11-2008, 19:14
ciao, scusa ma ero senza linea adsl e ho letto solo ora

tcp 0 0 0.0.0.0:10200 0.0.0.0:* LISTEN
udp 0 0 0.0.0.0:10200 0.0.0.0:*

Questo è qullo che leggo con il comando che mi hai detto.

Ti ringrazio.

Fabio.

sacarde
30-11-2008, 09:24
sembrerebbe a posto...



p.s.
apache ce l'hai? funziona?

fleone
01-12-2008, 14:05
ciao, c'è httpd attivo e funzionante, effettivamente prima non funzionava, mi dava un problema sulla liberia libldap32 poi gli arubiani l'hanno risolto perché io anche da root non riuscio a cancellare alcuni files.

L'installazione di webmin è filata liscia, non capisco proprio perché questo problema sull'accesso. Ti ringrazio.

Fabio.

sacarde
01-12-2008, 14:21
mah


hai accesso ai log? vedi qualcosa su webmin

fleone
01-12-2008, 18:26
aprendo il log, ti prendo l'ultimo errore:

[28/Nov/2008:17:42:49 +0100] miniserv.pl started
[28/Nov/2008:17:42:49 +0100] Perl module Authen::PAM needed for PAM is not installed : Can't locate Authen/PAM.pm in @INC (@INC contains: /usr/libexec/webmin /usr/lib/perl5/site_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7 /usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5 /usr/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.8.8/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.7/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.6/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.5/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7 /usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.8.8/i386-linux-thread-multi /usr/lib/perl5/5.8.8 .) at (eval 10) line 1.
BEGIN failed--compilation aborted at (eval 10) line 1.

Failed to bind to port 10200 : Address already in use
Could not listen on any ports at /usr/libexec/webmin/miniserv.pl line 428.

noto che mi dice adress already in use... sarà mica occupata come porta?

sacarde
01-12-2008, 20:57
l'installazione di webmin ha risolto tutte le dipendenze?

qui dice:
modulo perl Authen::PAM non installato



p.s.
prova un'altra porta

fleone
02-12-2008, 10:42
si, non mi ha dato nessun problema durante l'installazione. Ho provato ad installare il modulo PAM con yum install PAM.i386 ma mi dice che è già installato.

Grazie ancora per il tuo interessamento..

ho cambiato porta ma rimane tutto uguale. Non funge.

sacarde
02-12-2008, 11:10
Authen::PAM non e' PAM, e' un modulo perl

si installa con cpan o scaricando il modulo e installandolo


vedi "Installare dei moduli Perl in Linux"


http://www.igsuite.org/cgi-bin/igwiki/faq21

Loading