PDA

Visualizza la versione completa : Errore durante l`installazione di Unreal IRCD aiuto


or_alberto
28-11-2008, 18:58
Ciao a tutti mi sono comprato un server e volevo installare sopra Unreal IRCD
durante linstallazione faccio

./Config
poi dopo un po mi esce questo errore:

./configure --with-showlistmodes --enable-hub --enable-prefixaq --with-listen=5 --with-dpath=/home/user001/Unreal3.2 --with-spath=/home/user001/Unreal3.2/src/ircd --with-nick-history=2000 --with-sendq=3000000 --with-bufferpool=18 --with-hostname=km13826.keymachine.de --with-permissions=0600 --with-fd-setsize=1024 --enable-dynamic-linking
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
user001@km13826:~/Unreal3.2$

io ho accesso anche root che devo installare?

SUPERMIKY
28-11-2008, 20:00
Originariamente inviato da or_alberto
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
user001@km13826:~/Unreal3.2$

io ho accesso anche root che devo installare?

come suggerisce il messaggio di errore devi installare un compilatore C

or_alberto
28-11-2008, 20:41
dove lo posso prendere e come lo installo?

SUPERMIKY
28-11-2008, 21:24
che distro hai?

comunque sulle più comuni i comandi sono:

sudo apt-get install build-essential
[ubuntu e simili]

yum install gcc
[fedora e simili]

or_alberto
28-11-2008, 21:32
il sistema che ho e:

DEBIAN

SUPERMIKY
28-11-2008, 22:10
allora va benissimo "apt-get install gcc"
ps: sposto in LINUX

or_alberto
29-11-2008, 06:07
bene adesso mi da questo tipo di errore:

[]->
./configure --with-showlistmodes --enable-hub --enable-prefixaq --with-listen=5 --with-dpath=/home/user001/Unreal3.2 --with-spath=/home/user001/Unreal3.2/src/ircd --with-nick-history=2000 --with-sendq=3000000 --with-bufferpool=18 --with-hostname=km13826.keymachine.de --with-permissions=0600 --with-fd-setsize=1024 --enable-dynamic-linking
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
user001@km13826:~/Unreal3.2$

francofait
29-11-2008, 09:14
il compilatore per essere completo ha bisogno del make e delle principali librerie di sistema , se ti sei limato ad installare gcc chiaramente non può crearti l' eseguibile .

apt-get install make

Loading