PDA

Visualizza la versione completa : installare apxs


yaya
03-12-2008, 14:20
premessa grande come una casa: conosco poco linux, c'ho lavorato un pò anni fa e sempre supportata quindi siate buoni :zizi:

Ho fatto delle prove su windows per installare il connettore mod_jk tra apache e tomcat, tutto ok. Quando sono andata ad configurarlo su linux non ce l'ho fatta.
Lavoro su un server Linux (Fedora 8) con web server Apache 2, PHP 5, MySQL 5.

Il file so era già installato ma non funzionava, ho pensato quindi di rifare l'installazione da zero e ho visto che il file andava ricompilato.

Mi sono messa lì con le mie istruzioni:
$> cd native
$> ./configure --with-apxs=/usr/sbin/apxs (or where ever the apxs/apxs2 is)
$> make
$> su -c 'make install'

Ottimo, apxs non c'è!!!
Amico google mi viene incontro e trovo che per installarlo dovrei fare
yum install httpd-devel

ma mi dice:

Error: Missing Dependency: cyrus-sasl-lib = 2.1.22-7 is needed by package cyrus-sasl-devel
Error: Missing Dependency: openldap = 2.3.38-3.fc8 is needed by package openldap-devel
Error: Missing Dependency: httpd = 2.2.6-3 is needed by package httpd-devel

:dhò:

Ora sono un pò bloccata qua, quanche aiutino?

yaya
03-12-2008, 16:49
ho scoperto insieme al sistemista che quelle dipendenze mancanti in realtà ci sono e sono anche a versioni superiori delle richieste.
Per ora abbandono il mod_jk e tento con il mod_proxy però se a qualcuno venisse qualche idea di come aggirare il problema sarei curiosa anche sono per "bagaglio culturale"

Loading