PDA

Visualizza la versione completa : Canon Pixma iP1600


danilok
19-12-2008, 13:44
Ciao a tutti.
Con Ubuntu 8.04 la mia Canon Pixma iP1600 funziona bene seguendo le guide dei vari forum; poi non funziona più: stesso con Ubuntu 8.10. Con Windows funziona benissimo.
Vi posto le risposte del terminale, secondo me non genero più adeguatamente i file .deb.

danilo@danilo-desktop:~$ tar -zvxf iP2200_Linux_260.tar.gz
cnijfilter-common-2.60-1.i386.rpm
cnijfilter-common-2.60-1.src.rpm
cnijfilter-ip2200-2.60-1.i386.rpm
cnijfilter-ip2200-lprng-2.60-1.i386.rpm
danilo@danilo-desktop:~$ sudo alien --to-deb cnijfilter-common-*.i386.rpm
cnijfilter-common_2.60-2_i386.deb generated
danilo@danilo-desktop:~$ sudo alien --to-deb cnijfilter-ip2200-*.i386.rpm
Warning: Skipping conversion of scripts in package cnijfilter-ip2200: postinst postrm
Warning: Use the --scripts parameter to include the scripts.
cnijfilter-ip2200_2.60-2_i386.deb generated
Warning: Skipping conversion of scripts in package cnijfilter-ip2200-lprng: postrm
Warning: Use the --scripts parameter to include the scripts.
cnijfilter-ip2200-lprng_2.60-2_i386.deb generated
danilo@danilo-desktop:~$

E' un problema di alien? Ditemi cosa posso fare o divento matto!!!
:dhò:

sacarde
20-12-2008, 17:43
lo sai il francese?

http://forum.ubuntu-fr.org/viewtopic.php?id=61554

mykol
20-12-2008, 17:59
la canon non supporta Linux a quanto ne so (se la situazione non è cambiata recentemente). Evita per il futuro di acquistare prodotti canon, scegli Epson o Brother (dopo aver controllato quali sono i modelli supportati ...). Per il presente ... non lo so !

danilok
20-12-2008, 18:44
La cosa ridicola è che la stampante funziona benissimo con Linux, o almeno lo faceva sino a questa estate, e proprio con quegli script che ho postato; mi devo rassegnare a comprare un altra stampante? Comunque grazie dei suggerimenti, proverò.

francofait
20-12-2008, 19:31
Originariamente inviato da danilok
La cosa ridicola è che la stampante funziona benissimo con Linux, o almeno lo faceva sino a questa estate, e proprio con quegli script che ho postato; mi devo rassegnare a comprare un altra stampante? Comunque grazie dei suggerimenti, proverò.

Dal momento che per installarli i driver devi convertire da .rpm a.deb proprio i driver per mandriva , prima di cambiare la stampante io proverei a cambiare distro in modo da evitare alien.

sacarde
20-12-2008, 21:00
e usare rpm2targz

e installare quelli ?

mykol
20-12-2008, 21:59
cambiare stampante penso sia proprio l'ultima cosa ...

danilok
22-12-2008, 15:42
rpm2targz ? Come funziona?

sacarde
22-12-2008, 20:19
rpm2targz trasforma il pacchetto in forma tar.gz

poi lo installi con

tar -xvfz <nomefile.tar.gz> -C /

Loading