PDA

Visualizza la versione completa : Procmail e Spamassassin


Shork
27-12-2008, 17:01
Ciao a tutti,

sono nuovo con linux e vorrei mettere in piedi un server di posta...
Ho Fedora 9 con Postfix/Dovecot e tutto file liscio, le email escono ed entrano... :), ora vorrei aggiungere un motore anti spam e pensavo a Spamassassin... qualcuno mi pu spiegare, passo dopo passo, come fare... incluso il discorso procmail (inserito nella home di ogni utente, nella etc... sono un p confuso)...

Grazie in anticipo e auguri a tutti

mmbarabba
28-12-2008, 01:44
tu usi fedora , ma per debian una guida c' :unz:
come fare un mail server (http://guide.debianizzati.org/index.php/Mail_Server)

potresti vedere li come configurato spamassassin e procmail

sacarde
28-12-2008, 09:31
http://www.fedoraonline.it/modules/smartsection/item.php?itemid=198

Shork
31-12-2008, 00:08
Ho provato a seguire le istruzioni...
1. Installato spamassassin
2. Creato il file /etc/procmailrc
3. Inserito nel procmailrc il seguente codice:



DROPPRIVS=yes
LOGFILE=/var/log/procmail.log
VERBOSE=yes

:0fw
* < 256000
## | spamc -f
| /usr/bin/spamassassin

:0:/tmp/spam.lock
*^X-Spam-Flag: YES
$HOME/mail/SPAM

La mia posta in formato mbox e vorrei che lo spam fosse diviso per utente (e quindi consultabile)

4. Abilitato in postfix l'uso del procmail


mailbox_command = /usr/bin/procmail -a "$SENDER $RECIPIENT $EXTENSION"

Il risultato che non ho nessun file di LOG e la mail che arriva non ha alcun header dello spamassassin...

Mi sfugge qualcosa...? (domanda retorica)

Grazie

sacarde
31-12-2008, 09:17
- che guida hai seguito?

- neanche messaggi in altri log?


http://fedoraproject.org/wiki/Docs/Drafts/AdministrationGuide/Servers/MailServer/Procmail

Shork
31-12-2008, 13:53
- che guida hai seguito?
Beh, diverse qua e la...


- neanche messaggi in altri log?

Ho provato a guardare in maillog e messages ma nulla... e come se il procmailrc non venisse usato... eppure in posfix l'ho inserito... :dh:

sacarde
31-12-2008, 14:05
esempio:

io vedo :

:0fw

e non

:0 fw

Shork
02-01-2009, 14:44
Ho provato a lanciare il procmail command line funziona... il problema sembra sia postfix che non lo esegue...

sacarde
02-01-2009, 17:16
domanda banale

ma postfix gira?
il servizio e' avviato?

Shork
02-01-2009, 20:34
certo, le email girano...

Loading