PDA

Visualizza la versione completa : Linux su portatile....e i driver?


marco75_li
02-01-2009, 17:57
Ciao,

sto provando ad installare linux mint 6 e ubuntu 8.10 (perchè la 8.04 non mi gira bene non so perchè) su un portatile Asus Pro72LSeries, di preciso il X71SL.

Sono ancora un neofita anche se inizio ormai a muovere i primi passi in linux.
Mi spiegate gentilmente come fare ad installare un driver mancante?
Per esempio... non mi funziona l'audio, in win installi il driver e via e in linux? come si fa?

Non prendetevela, magari vi sembrerà una domanda molto banale, ma meglio sempre chiedere no!?

grazie a tutti fin d'adesso!

psykopear
02-01-2009, 18:08
Originariamente inviato da marco75_li
Ciao,

sto provando ad installare linux mint 6 e ubuntu 8.10 (perchè la 8.04 non mi gira bene non so perchè) su un portatile Asus Pro72LSeries, di preciso il X71SL.

Sono ancora un neofita anche se inizio ormai a muovere i primi passi in linux.
Mi spiegate gentilmente come fare ad installare un driver mancante?
Per esempio... non mi funziona l'audio, in win installi il driver e via e in linux? come si fa?

Non prendetevela, magari vi sembrerà una domanda molto banale, ma meglio sempre chiedere no!?

grazie a tutti fin d'adesso!

Dipende dalla scheda audio, poi si installa tutto dal gestore di pacchetti, o al limite si possono compilare i driver. Come appena detto, facci sapere il modello della scheda audio (se non lo sai, apri un terminale e digita "lspci" senza virgolette, e poi posta qui il risultato)

paolino_delta_t
02-01-2009, 18:17
i driver linux li fornisce nel kernel, quindi come regola generica, se l'hardware non va è probabile che non sia supportato

questo non sempre è vero....ad esempio alcune schede di rete Realtek fanno a botte con il driver fornito di default, ma basta compilarselo da sorgenti e il gioco è fatto

mi pare strano che proprio l'audio dia problemi, visto che ormai i chipset audio sono standardizzati....è possibile nel tuo caso che Ubuntu abbia impostato piuttosto l'uscita HDMI Audio come default oppure abbia messo in mute le uscite audio

la prima cosa da fare è capire che chipset audio hai

per fare questo apri un terminale ( Applicazioni -> Accessori -> Terminale ) e dai il comando lspci

poi posta l'output qui

per verificare se il driver è caricato dai nel terminale il comando lsmod | grep intel dovrebbe listare i moduli caricati

intanto puoi vedere se i settaggi sono ok ..... vai col mouse sull'icona dell'altoparlante in alto a destra e clicca col tasto sinistro....uscirà un menù

verifica che Esclusi Audio non sia ovviamente spuntato....poi clicca su Preferenze, si aprirà una finestra dove dovrebbe esserci scritto tra l'altro qualcosa del tipo "HDA Intel ( Alsa Mixer )"

infine apri Regolazione volume e verificare che i vari slider non sono a zero e che i canali corrispondenti non sono in mute ( l'altoparlante con la x accanto ) e l'altoparlante con sopra un divieto d'accesso

marco75_li
02-01-2009, 20:54
marco@marco-laptop:~$ lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] 671MX
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (rev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.1 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethernet Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mode (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0d.0 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 05)
00:0d.1 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 22)
00:0d.2 System peripheral: Ricoh Co Ltd R5C592 Memory Stick Bus Host Adapter (rev 12)
00:0d.3 System peripheral: Ricoh Co Ltd xD-Picture Card Controller (rev 12)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
01:00.0 VGA compatible controller: nVidia Corporation GeForce 9300M GS (rev a1)
02:00.0 Network controller: Atheros Communications Inc. AR928X Wireless Network Adapter (PCI-Express) (rev 01)
marco@marco-laptop:~$


-----

marco@marco-laptop:~$ lsmod | grep intel
snd_hda_intel 381488 3
snd_pcm 83204 2 snd_hda_intel,snd_pcm_oss
snd 63268 15 snd_hda_intel,snd_pcm_oss,snd_mixer_oss,snd_pcm,sn d_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_de vice
snd_page_alloc 16136 2 snd_hda_intel,snd_pcm
marco@marco-laptop:~$

marco75_li
02-01-2009, 20:56
aiuto! :dhò:

paolino_delta_t
02-01-2009, 21:43
non ci sono problemi degni di nota segnalati nei forum di ubuntu e da quello che vedo la scheda è riconosciuta e i driver sono tutti perfettamente caricati

hai provato a verificare se i canali sono muted, come ti ho suggerito?

inoltre cos'è che non riproduce? stai provando a riprodurre file mp3, wma, ecc???? se è così tieni presente che bisogna installare i codec perchè siano riproducibili

per vedere se l'audio funziona vai in Sistema->Preferenze->Audio e clikka su uno dei pulsanti Prova

una volta verificato tutto quello che ho detto, l'unica causa rimane l'incompatibilità con l'acpi....in questo caso apri il terminale e digiti sudo gedit /etc/modprobe.d/alsa-base ..... si aprirà un editor con il file, vai alla fine del file e aggiungi options snd-hda-intel model=laptop e riavvia il sistema

marco75_li
03-01-2009, 00:47
niente da fare.
ho fatto tutto.
ho aggiunto il tutto al file su indicato ma il pc è muto come un pesce.
Non è attivato il mute mode.
Ho controllato tutti i volumi e sono alzati.
Ma non esiste un aggiorna driver ?
Non sento nulla ne i file mp3 per i quali ho scaricato il codec, ne i suoni propri del sistema operativo...nulla.

bereshit
03-01-2009, 01:41
prova

sistema --> preferenze --> audio

prova le varie opzioni oltre alla identificazione automatica..

poi riprova a modificare come prima il file cambiandolo eprò in

options snd-hda-intel model=lenovo

i driver sono integrati nel kernel si aggiornano quando aggiorni il kernel.. ogni sei mesi.. se no te lo devi fare a mano.. niente clicchi e installi.. lo scarso supporto hai driver per linux è un problema storico.. dovuto alla scarsa diffusione..

anchio appena acquistato il portatile , l'ultima versione di ubuntu ( e altre distro) non mi faceva andare l'audio..l'ibernazione etc..

ho scoperto poi che era dovuto al fatto che la scheda audio era supportata solod a ll'ultima versione di alsa.. che le distor non avevano.. potevo instalalrlo ovviamente a mano.. ma ho optato ho usato una debina testing che me la riconosceva.. e qualche mese dopo con la nuova ubuntu .. no problem.. è cosi su linux.. il supporto hardware arriva dopo..

psykopear
03-01-2009, 10:02
magari controlla alsamixer: da terminale dai

alsamixer

e vedi se li i livelli sono muti o a zero. Se il problema è quello, sistemli, esci e poi digita

alsactl store

marco75_li
03-01-2009, 19:22
ho fatto tutto, ma niente da fare.
non capisco, come può un sistema operativo rilevare correttamente l'hardware ma poi non riuscire a gestirlo?
e cosa significa "compilare da solo i driver o che tutto si gestisce dall'installatore di pacchetti"?
Cioè se devo installare un software ok. lo cerco in una repositorye lo installo da li, ma per i driver mi sembra di aver capito che visto che sono integrati nel kernel di linux dovrò aspettare chissà quanto per sentire suonare il notebook.....

ho provato ubuntu 8.10 e linux mint 6
ma nessuna delle due mi fa sentire nulla.

pensavo che fossero le più "aggiornate"....

non c'è modo per aprire una specie di gestione risorse come in windows e cercar di far capire a linux che il tipo di scheda audio è quella e che voglio che utilizzi un determinato driver per farla suonare?
Ho provato sia con alsa....sia in auto ma non cambia nulla.
Si può aggiornare solo "alsa"?

Grazie...

Loading