PDA

Visualizza la versione completa : Versione del kernel


mxa
06-01-2009, 20:52
Sto sistemando il codice di un driver per farlo andare con gli ultimi kernel 2.6.2*, siccome lo vorrei tenere compatibile all'indietro vorrei qualcosa tipo
#if KERNEL < x
do this
#else
do that
#endif

ma cosa ci va al posto di KERNEL? in particolare mi interessa la variabile SUBLEVEL settata nel Makefile, ma non mi sembra sia passata al compilatore, o si'?

Loading