PDA

Visualizza la versione completa : compatibilita` glibc 2.1


pard
24-01-2009, 18:36
Mi servirebbe un suggerimento per installare un applicativo Zucchetti che dalle istruzioni di installazione richiede la GLIBC 2.1, vecchia di parecchi anni.
In base alla mia esperienza Linux sono molto perplesso che il prog possa funzionare con le glibc piu` recenti, altre installazioni che ho visto sono su vecchissime Suse.

Quindi, premesso che io conosco bene Redhat/Fedora e Slackware, ma non e` che ho problemi ad installare altre distro, mi preme solo che il programma funzioni.

Come posso fare per risolvere il problema?
A me venivano in mente tre ipotesi:
1. qualche distribuzione rilascia package di compatibilita` per le vecchie versioni delle librerie?
2. compilare in loco la glibc 2.1 sperando che l'applicativo se la ciucci tranquillamente da /lib senza fare casino, ma non so neanche se sia possibile compilare una vecchia glibc su un sistema con la nuova...
3. installare una distro vecchia con glibc 2.1 di serie, tipo Slack 7.0

Grazie.

hfish
24-01-2009, 20:15
ma hai provato a compilare con le ultime librerie? magari hai una botta di culo e tutto funziona lo stesso...

pard
25-01-2009, 13:54
Purtroppo trattandosi di sw commerciale non avro` mai i sorgenti, ci sono solo i binari che si trovano su un vecchio server e vanno trasferiti sui nuovi.
Al momento non posso provare nulla, ma volevo mettermi avanti se qualcuno sapeva come assicurare la compatibilita` binaria per l'app compilata con GLIBC 2.1

hfish
25-01-2009, 18:21
nei sistemi debian-based c' il comodo comando update-alternatives che sembrerebbe fare proprio al tuo caso, ma non so se una feature di debian o un comando comune...

Loading