PDA

Visualizza la versione completa : Problema montaggio cdrom


Neptune
26-03-2009, 20:42
Mi sono accorto solo ora (è da un pò di tempo che non infilo un cdrom) che non mi funzioan il cdrom.
Se do il comando "mount /dev/cdrom" mi appare scritto:



mount: special device /dev/cdrom does not exist


Ho controllato in /dev e pare che non esista proprio "cdrom" eppure nell'fstab ci sta scritto:



/dev/cdrom /media/cdrom udf,iso9660 noauto,ro,users 0 0


Ho provato a dare un dmesg è questo il risultato: (ve lo inserisco in un'altro messaggio o il post è troppo lungo)[..]

Dove nello specifico sembra rilevarmi il cdrom su hdb:


hdb: _NEC DVD_RW ND-3520A, ATAPI CD/DVD-ROM drive


Questo signfiica che i moduli del cdrom sono caricati correttamente giusto? perchè l'unico dubbio che mi era venuto è che ho ricompilato il kernel e quindi magari "non me li avesse caricati".

Altro dubbio è che sto utilizzando virtualbox-ose, che ha montato un iso dall'hd e che sta installando dall'iso, può essere per quello che invece non mi va?

Vi ringrazio in anticipo per l'aiuto,
Neptune.

Neptune
26-03-2009, 20:45
0:00:01.0: bridge 32bit mmio pref: [0x9fd00000-0xdfcfffff]
bus 00 -> node 0
ACPI: PCI Interrupt Routing Table [\_SB_.PCI0._PRT]
ACPI: PCI Interrupt Link [LNKA] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKB] (IRQs 3 4 5 6 7 *10 11 12 14 15)
ACPI: PCI Interrupt Link [LNKC] (IRQs 3 4 5 6 7 10 *11 12 14 15)
ACPI: PCI Interrupt Link [LNKD] (IRQs 3 4 *5 6 7 10 11 12 14 15)
ACPI: Power Resource [URP1] (off)
ACPI: Power Resource [URP2] (off)
ACPI: Power Resource [FDDP] (off)
ACPI: Power Resource [LPTP] (off)
PCI: Using ACPI for IRQ routing
NetLabel: Initializing
NetLabel: domain hash size = 128
NetLabel: protocols = UNLABELED CIPSOv4
NetLabel: unlabeled traffic allowed by default
pnp: PnP ACPI init
ACPI: bus type pnp registered
pnp 00:04: io resource (0x820-0x821) overlaps 0000:00:11.0 BAR 7 (0x800-0x87f), disabling
pnp: PnP ACPI: found 9 devices
ACPI: ACPI bus type pnp unregistered
system 00:04: ioport range 0x3f0-0x3f1 has been reserved
system 00:04: ioport range 0x4d0-0x4d1 has been reserved
system 00:04: ioport range 0x400-0x40f has been reserved
system 00:04: iomem range 0xfee00000-0xfee00fff has been reserved
pci 0000:00:01.0: PCI bridge, secondary bus 0000:01
pci 0000:00:01.0: IO window: 0xc000-0xcfff
pci 0000:00:01.0: MEM window: 0xdfe00000-0xdfefffff
pci 0000:00:01.0: PREFETCH window: 0x0000009fd00000-0x000000dfcfffff
pci 0000:00:01.0: setting latency timer to 64
bus: 00 index 0 io port: [0x00-0xffff]
bus: 00 index 1 mmio: [0x000000-0xffffffff]
bus: 01 index 0 io port: [0xc000-0xcfff]
bus: 01 index 1 mmio: [0xdfe00000-0xdfefffff]
bus: 01 index 2 mmio: [0x9fd00000-0xdfcfffff]
bus: 01 index 3 mmio: [0x0-0x0]
NET: Registered protocol family 2
IP route cache hash table entries: 32768 (order: 5, 131072 bytes)
TCP established hash table entries: 131072 (order: 8, 1048576 bytes)
TCP bind hash table entries: 65536 (order: 7, 524288 bytes)
TCP: Hash tables configured (established 131072 bind 65536)
TCP reno registered
NET: Registered protocol family 1
Unpacking initramfs... done
Freeing initrd memory: 6921k freed
highmem bounce pool size: 64 pages
HugeTLB registered 4 MB page size, pre-allocated 0 pages
VFS: Disk quotas dquot_6.5.1
Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)
msgmni has been set to 1734
alg: No test for lzf (lzf-generic)
alg: No test for stdrng (krng)
Block layer SCSI generic (bsg) driver version 0.4 loaded (major 254)
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered (default)
PCI: VIA PCI bridge detected.Disabling DAC.
pci 0000:01:00.0: Boot video device
vesafb: framebuffer at 0xc0000000, mapped to 0xf8080000, using 3072k, total 16384k
vesafb: mode is 1024x768x16, linelength=2048, pages=9
vesafb: protected mode interface info at c000:5849
vesafb: pmi: set display start = c00c58dd, set palette = c00c5929
vesafb: pmi: ports = c810 c816 c854 c838 c83c c85c c800 c804 c8b0 c8b2 c8b4
vesafb: scrolling: redraw
vesafb: Truecolor: size=0:5:6:5, shift=0:11:5:0
Console: switching to colour frame buffer device 128x48
fb0: VESA VGA frame buffer device
Linux agpgart interface v0.103
Serial: 8250/16550 driver4 ports, IRQ sharing enabled
serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
00:02: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
Fixed MDIO Bus: probed
input: Macintosh mouse button emulation as /devices/virtual/input/input0
Uniform Multi-Platform E-IDE driver
via82cxxx 0000:00:11.1: VIA vt8235 (rev 00) IDE UDMA133
via82cxxx 0000:00:11.1: IDE controller (0x1106:0x0571 rev 0x06)
pci 0000:00:11.1: can't derive routing for PCI INT A
via82cxxx 0000:00:11.1: not 100% native mode: will probe irqs later
ide0: BM-DMA at 0xfc00-0xfc07
ide1: BM-DMA at 0xfc08-0xfc0f
Probing IDE interface ide0...
hda: MAXTOR STM3160215A, ATA DISK drive
hdb: _NEC DVD_RW ND-3520A, ATAPI CD/DVD-ROM drive
hda: host max PIO5 wanted PIO255(auto-tune) selected PIO4
hda: UDMA/100 mode selected
hdb: host max PIO5 wanted PIO255(auto-tune) selected PIO4
hdb: UDMA/33 mode selected
Probing IDE interface ide1...
hdc: Maxtor 6E040L0, ATA DISK drive
hdc: host max PIO5 wanted PIO255(auto-tune) selected PIO4
hdc: UDMA/133 mode selected
ide0 at 0x1f0-0x1f7,0x3f6 on irq 14
ide1 at 0x170-0x177,0x376 on irq 15
ide-gd driver 1.18
hda: max request size: 512KiB
hda: 312581808 sectors (160041 MB) w/2048KiB Cache, CHS=19457/255/63
hda: cache flushes supported
hda: hda1 hda2 hda3
hdc: max request size: 128KiB
hdc: 80293248 sectors (41110 MB) w/2048KiB Cache, CHS=65535/16/63
hdc: cache flushes supported
hdc: hdc2 < hdc5 >
PNP: No PS/2 controller found. Probing ports directly.
serio: i8042 KBD port at 0x60,0x64 irq 1
serio: i8042 AUX port at 0x60,0x64 irq 12
mice: PS/2 mouse device common for all mice
cpuidle: using governor ladder
TCP cubic registered
Using IPI No-Shortcut mode
TuxOnIce 3.0-rc7 (http://tuxonice.net)
Replacing swsusp.
TuxOnIce: Resume= parameter is empty. Hibernating will be disabled.
Freeing unused kernel memory: 316k freed
processor ACPI_CPU:00: registered as cooling_device0
ACPI: Processor [CPU1] (supports 16 throttling states)
usbcore: registered new interface driver usbfs
usbcore: registered new interface driver hub
usbcore: registered new device driver usb
uhci_hcd: USB Universal Host Controller Interface driver
uhci_hcd 0000:00:10.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.0: UHCI Host Controller
uhci_hcd 0000:00:10.0: new USB bus registered, assigned bus number 1
uhci_hcd 0000:00:10.0: irq 21, io base 0x0000e400
usb usb1: configuration #1 chosen from 1 choice
hub 1-0:1.0: USB hub found
hub 1-0:1.0: 2 ports detected
usb usb1: New USB device found, idVendor=1d6b, idProduct=0001
usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb1: Product: UHCI Host Controller
usb usb1: Manufacturer: Linux 2.6.28.7-486-van-neptune uhci_hcd
usb usb1: SerialNumber: 0000:00:10.0
uhci_hcd 0000:00:10.1: PCI INT B -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.1: UHCI Host Controller
uhci_hcd 0000:00:10.1: new USB bus registered, assigned bus number 2
uhci_hcd 0000:00:10.1: irq 21, io base 0x0000e800
usb usb2: configuration #1 chosen from 1 choice
hub 2-0:1.0: USB hub found
hub 2-0:1.0: 2 ports detected
usb usb2: New USB device found, idVendor=1d6b, idProduct=0001
usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb2: Product: UHCI Host Controller
usb usb2: Manufacturer: Linux 2.6.28.7-486-van-neptune uhci_hcd
usb usb2: SerialNumber: 0000:00:10.1
uhci_hcd 0000:00:10.2: PCI INT C -> GSI 21 (level, low) -> IRQ 21
uhci_hcd 0000:00:10.2: UHCI Host Controller
uhci_hcd 0000:00:10.2: new USB bus registered, assigned bus number 3
uhci_hcd 0000:00:10.2: irq 21, io base 0x0000ec00
usb usb3: configuration #1 chosen from 1 choice
hub 3-0:1.0: USB hub found
hub 3-0:1.0: 2 ports detected
usb usb3: New USB device found, idVendor=1d6b, idProduct=0001
usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb3: Product: UHCI Host Controller
usb usb3: Manufacturer: Linux 2.6.28.7-486-van-neptune uhci_hcd
usb usb3: SerialNumber: 0000:00:10.2
via-rhine.c:v1.10-LK1.4.3 2007-03-06 Written by Donald Becker
via-rhine 0000:00:12.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
eth0: VIA Rhine II at 0xdffff600, 00:11:5b:80:14:36, IRQ 23.
eth0: MII PHY found at address 1, status 0x786d advertising 05e1 Link 45e1.
ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
Warning! ehci_hcd should always be loaded before uhci_hcd and ohci_hcd, not after
ehci_hcd 0000:00:10.3: PCI INT D -> GSI 21 (level, low) -> IRQ 21
ehci_hcd 0000:00:10.3: EHCI Host Controller
ehci_hcd 0000:00:10.3: new USB bus registered, assigned bus number 4
ehci_hcd 0000:00:10.3: irq 21, io mem 0xdffff700
ehci_hcd 0000:00:10.3: USB 2.0 started, EHCI 1.00
usb usb4: configuration #1 chosen from 1 choice
hub 4-0:1.0: USB hub found
hub 4-0:1.0: 6 ports detected
usb usb4: New USB device found, idVendor=1d6b, idProduct=0002
usb usb4: New USB device strings: Mfr=3, Product=2, SerialNumber=1
usb usb4: Product: EHCI Host Controller
usb usb4: Manufacturer: Linux 2.6.28.7-486-van-neptune ehci_hcd
usb usb4: SerialNumber: 0000:00:10.3
Floppy drive(s): fd0 is 1.44M
FDC 0 is a post-1991 82077
device-mapper: uevent: version 1.0.3
device-mapper: ioctl: 4.14.0-ioctl (2008-04-23) initialised: dm-devel@redhat.com
usb 1-1: new low speed USB device using uhci_hcd and address 2
PM: Starting manual resume from disk
Replacing swsusp.
TuxOnIce: Resume= parameter is empty. Hibernating will be disabled.
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: New USB device found, idVendor=093a, idProduct=2500
usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-1: Product: USB OPTICAL MOUSE
usb 1-1: Manufacturer: PIXART
usb 1-2: new low speed USB device using uhci_hcd and address 3

Neptune
26-03-2009, 20:46
usb 1-2: configuration #1 chosen from 1 choice
usb 1-2: New USB device found, idVendor=0603, idProduct=00f1
usb 1-2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
usb 1-2: Product: USB Keyboard
usb 1-2: Manufacturer: NOVATEK
udevd version 125 started
input: Power Button (FF) as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input1
ACPI: Power Button (FF) [PWRF]
input: Power Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input2
ACPI: Power Button (CM) [PWRB]
input: Sleep Button (CM) as /devices/LNXSYSTM:00/device:00/PNP0C0E:00/input/input3
ACPI: Sleep Button (CM) [SLPB]
agpgart: Detected VIA KM400/KM400A chipset
agpgart-via 0000:00:00.0: AGP aperture is 64M @ 0xe0000000
input: PC Speaker as /devices/platform/pcspkr/input/input4
rtc_cmos 00:06: RTC can wake from S4
rtc_cmos 00:06: rtc core: registered rtc_cmos as rtc0
rtc0: alarms up to one year, y3k, 114 bytes nvram
usbcore: registered new interface driver hiddev
input: PIXART USB OPTICAL MOUSE as /devices/pci0000:00/0000:00:10.0/usb1/1-1/1-1:1.0/input/input5
generic-usb 0003:093A:2500.0001: input,hidraw0: USB HID v1.10 Mouse [PIXART USB OPTICAL MOUSE] on usb-0000:00:10.0-1/input0
input: NOVATEK USB Keyboard as /devices/pci0000:00/0000:00:10.0/usb1/1-2/1-2:1.0/input/input6
generic-usb 0003:0603:00F1.0002: input,hidraw1: USB HID v1.10 Keyboard [NOVATEK USB Keyboard] on usb-0000:00:10.0-2/input0
Linux video capture interface: v2.00
input: NOVATEK USB Keyboard as /devices/pci0000:00/0000:00:10.0/usb1/1-2/1-2:1.1/input/input7
generic-usb 0003:0603:00F1.0003: input,hiddev96,hidraw2: USB HID v1.10 Mouse [NOVATEK USB Keyboard] on usb-0000:00:10.0-2/input1
usbcore: registered new interface driver usbhid
usbhid: v2.6:USB HID core driver
saa7130/34: v4l2 driver version 0.2.14 loaded
saa7134 0000:00:09.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
saa7133[0]: found at 0000:00:09.0, rev: 209, irq: 17, latency: 32, mmio: 0xdffff800
saa7133[0]: subsystem: 0070:6701, board: Hauppauge WinTV-HVR1110 DVB-T/Hybrid [card=104,insmod option]
saa7133[0]: board init: gpio is 6400000
saa7133[0]: i2c eeprom 00: 70 00 01 67 54 20 1c 00 43 43 a9 1c 55 d2 b2 92
saa7133[0]: i2c eeprom 10: ff ff ff 0e ff 20 ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 20: 01 40 01 32 32 01 01 33 88 ff 00 aa ff ff ff ff
saa7133[0]: i2c eeprom 30: ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff ff
saa7133[0]: i2c eeprom 40: ff 21 00 c2 96 10 03 32 15 60 ff ff ff ff ff ff
saa7133[0]: i2c eeprom 50: ff 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 60: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 70: 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom 80: 84 09 00 04 20 77 00 40 48 72 0d f0 73 05 29 00
saa7133[0]: i2c eeprom 90: 84 08 00 06 cb 05 01 00 94 38 89 72 07 70 73 09
saa7133[0]: i2c eeprom a0: 23 5f 73 0a fc 72 72 0b 2f 72 0e 01 72 0f 03 72
saa7133[0]: i2c eeprom b0: 10 01 72 11 1f 79 67 00 00 00 00 00 00 00 00 00
saa7133[0]: i2c eeprom c0: 84 09 00 04 20 77 00 40 48 72 0d f0 73 05 29 00
saa7133[0]: i2c eeprom d0: 84 08 00 06 cb 05 01 00 94 38 89 72 07 70 73 09
saa7133[0]: i2c eeprom e0: 23 5f 73 0a fc 72 72 0b 2f 72 0e 01 72 0f 03 72
saa7133[0]: i2c eeprom f0: 10 01 72 11 1f 79 67 00 00 00 00 00 00 00 00 00
tuner' 1-004b: chip found @ 0x96 (saa7133[0])
tveeprom 1-0050: Hauppauge model 67019, rev B3B4, serial# 881224
tveeprom 1-0050: MAC address is 00-0D-FE-0D-72-48
tveeprom 1-0050: tuner model is Philips 8275A (idx 114, type 4)
tveeprom 1-0050: TV standards PAL(B/G) NTSC(M) PAL(I) SECAM(L/L') PAL(D/D1/K) ATSC/DVB Digital (eeprom 0xfc)
tveeprom 1-0050: audio processor is SAA7131 (idx 41)
tveeprom 1-0050: decoder processor is SAA7131 (idx 35)
tveeprom 1-0050: has radio, has IR receiver, has IR transmitter
saa7133[0]: hauppauge eeprom: model=67019
tda829x 1-004b: setting tuner address to 61
tda829x 1-004b: type set to tda8290+75a
input: HVR 1110 as /devices/virtual/input/input8
ir-kbd-i2c: HVR 1110 detected at i2c-1/1-0071/ir0 [saa7133[0]]
saa7133[0]: registered device video0 [v4l2]
saa7133[0]: registered device vbi1
saa7133[0]: registered device radio0
VIA 82xx Audio 0000:00:11.5: PCI INT C -> GSI 22 (level, low) -> IRQ 22
VIA 82xx Audio 0000:00:11.5: setting latency timer to 64
dvb_init() allocating 1 frontend
DVB: registering new adapter (saa7133[0])
DVB: registering adapter 0 frontend 0 (Philips TDA10046H DVB-T)...
tda1004x: setting up plls for 48MHz sampling clock
tda1004x: found firmware revision 29 -- ok
Adding 2249092k swap on /dev/hda2. Priority:-1 extents:1 across:2249092k
EXT3 FS on hda3, internal journal
saa7134 ALSA driver for DMA sound loaded
saa7133[0]/alsa: saa7133[0] at 0xdffff800 irq 17 registered as card -1
vboxdrv: Trying to deactivate the NMI watchdog permanently...
vboxdrv: Successfully done.
vboxdrv: Found 1 processor cores.
vboxdrv: TSC mode is 'synchronous', kernel timer mode is 'normal'.
vboxdrv: Successfully loaded version 2.1.4_OSE (interface 0x000a0009).
fuse init (API version 7.10)
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
powernow: PowerNOW! Technology present. Can scale: frequency and voltage.
powernow: Trying ACPI perflib
powernow: ACPI perflib can not be used in this platform
powernow: ACPI and legacy methods failed
powernow: See http://www.codemonkey.org.uk/projects/cpufreq/powernow-k7.html
[drm] Initialized drm 1.1.0 20060810
pci 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[drm] Initialized radeon 1.29.0 20080528 on minor 0
eth0: no IPv6 routers present
agpgart-via 0000:00:00.0: AGP 3.5 bridge
agpgart: BIOS bug. AGP bridge claims to only support x4 rateFixing up support for x2 & x1
agpgart-via 0000:00:00.0: bridge is in legacy mode, falling back to 2.x
agpgart-via 0000:00:00.0: putting AGP V2 device into 4x mode
pci 0000:01:00.0: putting AGP V2 device into 4x mode
[drm] Setting GART location based on new memory map
[drm] Loading R300 Microcode
[drm] Num pipes: 1
[drm] writeback test succeeded in 1 usecs
warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0


Io butterei anche un'occhio sulle ultime righe dove dice "warning: 'virtualbox.....", che significa?

Neptune
26-03-2009, 20:57
Ho riavviato sul kernel precompilato da sidux ed invece va il cdrom, ergo non ho aggiunto il modulo per il cdrom nel momento della compilazione? come faccio ad aggiungerlo ora?

Neptune
26-03-2009, 21:14
Mi sono accorto, dano make menuconfig, che "include ide/atapi cdrom support" era deselezionato, lo selezionato come modulo e poi ho dato make-kpkg --append_to_version -486 --initrd --revision=rev.03 modules_image però mi ha compilato solo il modulo di virtualbox e non mi ha creato nessun pacchetto riguardo il cdrom. C'è bisogno di dargli un "make-kpkg clean" per fargli prendere il nuovo file di configurazione? oppure dov'è che sbaglio?

GunMan
27-03-2009, 02:50
c'è di sicuro qualche opzione sballata nella configurazione del kernel, visto che (ad occhio) c'è un po' di confusione direi di procedere in questo modo:

prima di qualsiasi altra cosa


$ make-kpkg clean nella dir dei sorgenti

successivamente controlla che queste opzioni siano presenti nella config
gli output sono a titolo di esempio, è per farti capire le impostazioni basilari, ovviamente nel caso sistemale per le tue necessità



$ cat /boot/config-`uname -r` | grep CONFIG_BLK_DEV_IDE
# CONFIG_BLK_DEV_IDE_SATA is not set
CONFIG_BLK_DEV_IDECD=y
CONFIG_BLK_DEV_IDECD_VERBOSE_ERRORS=y
CONFIG_BLK_DEV_IDETAPE=m
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_BLK_DEV_IDEACPI is not set
CONFIG_BLK_DEV_IDEPNP=y
CONFIG_BLK_DEV_IDEDMA_SFF=y
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_BLK_DEV_IDEDMA=y




$ cat /boot/config-`uname -r` | grep CONFIG_ISO9660_FS
CONFIG_ISO9660_FS=m


con questo in teoria dovresti essere a posto, eventualmente fai un diff tra il kernel funzionante e quello che da problemi, li sicuramente rintracci l'inghippo.

edit:
devi ricompilare il tutto naturalmente, puoi usare make-kpkg in ambiente fakeroot (come già sai) una cosa del genere


$ fakeroot make-kpkg --revision=0.1 --append-to-version -neptune kernel_image

Neptune
27-03-2009, 13:13
Originariamente inviato da GunMan
c'è di sicuro qualche opzione sballata nella configurazione del kernel, visto che (ad occhio) c'è un po' di confusione direi di procedere in questo modo:

prima di qualsiasi altra cosa


$ make-kpkg clean nella dir dei sorgenti

successivamente controlla che queste opzioni siano presenti nella config
gli output sono a titolo di esempio, è per farti capire le impostazioni basilari, ovviamente nel caso sistemale per le tue necessità



$ cat /boot/config-`uname -r` | grep CONFIG_BLK_DEV_IDE
# CONFIG_BLK_DEV_IDE_SATA is not set
CONFIG_BLK_DEV_IDECD=y
CONFIG_BLK_DEV_IDECD_VERBOSE_ERRORS=y
CONFIG_BLK_DEV_IDETAPE=m
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_BLK_DEV_IDEACPI is not set
CONFIG_BLK_DEV_IDEPNP=y
CONFIG_BLK_DEV_IDEDMA_SFF=y
CONFIG_BLK_DEV_IDEPCI=y
CONFIG_BLK_DEV_IDEDMA_PCI=y
CONFIG_BLK_DEV_IDEDMA=y




$ cat /boot/config-`uname -r` | grep CONFIG_ISO9660_FS
CONFIG_ISO9660_FS=m


con questo in teoria dovresti essere a posto, eventualmente fai un diff tra il kernel funzionante e quello che da problemi, li sicuramente rintracci l'inghippo.

edit:
devi ricompilare il tutto naturalmente, puoi usare make-kpkg in ambiente fakeroot (come già sai) una cosa del genere


$ fakeroot make-kpkg --revision=0.1 --append-to-version -neptune kernel_image

Ho risolto, mancava solo guardacaso il modulo per il supporto del cdrom, "include ide/atapi cdrom support", mi chiedo come ho fatto a dimenticarmi proprio quel modulo il cui utilizzo è tanto chiaro :zizi:

Loading