PDA

Visualizza la versione completa : [.bash_profile & bashrc]


00FUMI
28-03-2009, 21:32
Come da oggetto stamattina ho giocato un po troppo con questi due file e ora appena apro la shell il mio prompt e cosi:

sh-3.2$

qualcuno puo darmi una mano a sistemarli (per riavere i prompt predefinito di sistema) perfavore


-questo problema lo ho solo come user , come root tutto funziona alla normalita.

ps : il mio sistema Op e' un fedora core 9.

grazie mille

cacao74
28-03-2009, 22:26
vedi se hai un /etc/skel/.bashrc (idem per il profile)

altrimenti ripersonalizzateli come meglio credi.

ciao

sacarde
29-03-2009, 10:09
hai cambiato anche la shell in

/etc/passwd

?

00FUMI
29-03-2009, 10:17
Per cacao74 : i file li ho entrambi (/et/skel/.bashrc & /etc/skel/.bash_profile)

Quando dici personalizzali come meglio credi : e' proprio li il mio problema non so proprio come fare , ed e' proprio li
che chiedo una mano.


Per Scarade : no non ho modificato il file /etc/password!

Grazie ad entrambi per le risposte

sacarde
29-03-2009, 10:43
ma hai modificato

.bash_profile & .bashrc

quelli dell'utente o in /etc

?

00FUMI
30-03-2009, 09:42
al 90 % credo quelli user cioe : /home/MioNome/.bashrc



infatti quando provo ad invocare dentro la mia home (da terminale) il comando . .bashrc tutto torna alla normalita' , solo che ogni volta che chiudo la shell o riavvio il sistema mi viene fuori sempre il prompt come indicato prima.



HELP ME!

sacarde
30-03-2009, 10:23
che hai :


cat /etc/passwd | grep <tuoutente>

00FUMI
30-03-2009, 10:59
che hai :


cat /etc/passwd | grep <tuoutente> ?

Spero che con "che hai" , tu voglia dire "cosa restituisce?"

Altrimenti non ho capito!

Comunque se e' quello che dico io , il risultato e' questo:

[pluto@localhost etc]$ cat passwd | grep pluto
pluto:x:500:500:paolo:/home/paolo:/bin/sh


pardon se ho sbagliato qualcosa nell "interpretazione" :-).

sacarde
30-03-2009, 12:21
quiandi avevi modificato la shell di default



edita da root il file /etc/passwd
e al posto di

/bin/sh

metti

/bin/bash

00FUMI
30-03-2009, 14:10
Risolto modificando il file etc/passwd come suddetto da sacarde.


Grazie mille della collaborazione!

Loading