PDA

Visualizza la versione completa : Dansguardian in Debian Sid non installabile...


griphon
09-04-2009, 10:25
Come da oggetto, se si prova ad installare Dansguardian presente nella Debian Sid purtroppo si blocca e da' errore, in quanto richiede la libreria libclamav5 ormai non più presente, poichè sostituita dall'ultima più aggiornata libclamav6.
Come sistemare la cosa?
:ciauz:

sacarde
09-04-2009, 12:06
dagli indici risultano ancora entrambe:

http://packages.debian.org/sid/libclamav5
http://packages.debian.org/sid/libclamav6

http://packages.debian.org/sid/dansguardian

griphon
09-04-2009, 15:32
Purtroppo il pacchetto disponibile per Sid è solamente per cpu m68k quindi ho risolto così:

- ho disistallato tutto ciò che riguarda clamav
- ho aggiunto la repository debian unstable visto che lì libclamav5 c'e'
- ho aggiornato la lista pacchetti ed installato in seguito il solo pacchetto libclamav5
- ho poi reinstallato clamav e compagnia bella (fortuna che la libclamav6 non è andata in conflitto con la libclamav5!!!!!)
- ho infine installato Dansguardian, e finalmente non ha dato problemi.

Tutto è filato liscio.
:ciauz:

Neptune
09-04-2009, 17:29
Originariamente inviato da griphon
- ho aggiunto la repository debian unstable visto che lì libclamav5 c'e'


Mi deve eassere sfuggito qualcosa, ma Sid non è già l'unstable? non è Etch la stable, Squeeze la testing e Sid la unstable?

griphon
09-04-2009, 20:40
Emh... ho sbagliato io; intendevo il repository della testing.
:ciauz:

gio14
10-04-2009, 02:45
Originariamente inviato da griphon
Purtroppo il pacchetto disponibile per Sid è solamente per cpu m68k quindi ho risolto così:

- ho disistallato tutto ciò che riguarda clamav
- ho aggiunto la repository debian unstable visto che lì libclamav5 c'e'
- ho aggiornato la lista pacchetti ed installato in seguito il solo pacchetto libclamav5
- ho poi reinstallato clamav e compagnia bella (fortuna che la libclamav6 non è andata in conflitto con la libclamav5!!!!!)
- ho infine installato Dansguardian, e finalmente non ha dato problemi.

Tutto è filato liscio.
:ciauz:

Magari potevi risolvere semplicemente scaricandoti il pacchetto libclamav5 dal sito Debian e installarlo semplicemente con "dpkg -i libclamav5", quando voglio tornare ad una numerazione più vecchia di un pacchetto di solito risovo in questo modo, così facendo mi sotituisce la versione aggiornata con la vecchia, poi nel tuo caso se non cerano conflitti tra i due pacchetti ti avrebbe lasciato anche libclamav6

Loading