PDA

Visualizza la versione completa : ubuntu problemi di configurazione rete...


marco75_li
29-05-2009, 11:15
Ciao a tutti,

ho un problema che mi sta facendo diventare matto.
Ho un fisso con winXP e un portatile con ubuntu con dentro samba e tutto il resto.
Ho parecchie curiosità che non sono ancora riuscito a risolvere. Non capisco ad esempio dove posso inserire il nome del gruppo su ubuntu (quello che normalmente si chiama workgroup in windows.)
La stranezza sta nel fatto che riavviando il portatile capita quasi a caso che io possa accedere al pc in rete (il fisso) perchè vedo le cartelle condivise, ci posso leggere, scrivere..tutto insomma.
Dopo qualche minuto cominciano i problemi.
O non vedo più nulla oltre Rete di Windows (spariscono tutte le icone) oppure come adesso vedo il gruppo di lavoro, il pc fisso e le cartelle sia le condivise classiche sia le condivise a carattere amministrativo.
Quelle a carattere amministrativo mi richiedono una user e una password che non ho ben capito quali siano, mentre se certo di accedere alla cartella condivisa in maniera classica su windows alla quale accedevo fino a pochi minuti fa, adesso mi dice impossibile trovare il file.
In questo esatto momento sono riuscito ad accedere nuovamente alla cartella!!!
Assurdo.
Preciso che da windows non riesco a vedere le cartelle condivise dal notebook ma presumo che questo derivi dal fatto che oltre che nel file di configurazione di samba non ho trovato un altro "posto" dove inserire il nome del gruppo di lavoro...
Qualcuno mi saprebbe dare una mano?
Grazie!

sacarde
29-05-2009, 13:39
letto ?

http://wiki.ubuntu-it.org/Server/Samba?

marco75_li
29-05-2009, 14:04
certo sacarde.... è stata la prima cosa che ho letto.
il problema però è che seguendo pedessiquamente quel tutrial in realtà non si arriva a nulla.
Ho modificato il file smb.conf con alcune modifiche trovate qui e là su internet, samba4 non risulta installato sul portatile, ho installato i files che gestiscono le condivisioni (su ubuntu), e ora stranamente vedo il pc linux da windows (evviva) e il pc windows da linux (evviva2).
Il problema però deriva dal fatto che quando piace a lui riesco ad accedere alle condivise di entrambi i pc, mentre quando a lui non va tira fuori messagi del tipo condivisione scaduta, accesso non permesso...... e dopo 10 minuti tutto fila liscio come l'olio.
Premetto che dal browser dando smb://nome pc oppure ip vsiono regolarmente il tutto.
Il problema è se voglio accederci da sistema rete.
Vedo Rete di Windows, vedo il mio gruppo, vedo il pc windows, e vedo le condivise.
Il problema è che a volte sono accessibili, a volte no!
E io non cambio assoutamente nulla.
Capita infatti che mentre lavoro sulla condivisa per qualche motivo la condivisione vafa a farsi benedire, il pc ospite si blocca e si deve riavviare il tutto.
Ho installato sul portatile anche webmin ma in realtà dopo aver girato un bel pò su webmin l'unica modifica sostanziale è stata quella testuale apportata al file di configurazione di samba dove ho impostato il gruppo di lavoro, gli ip permessi, lo sharing dele cartelle e le permission.

Ma pechè linux deve fare così!!!
:-)

Loading