PDA

Visualizza la versione completa : problema con GRUB


agostino.pinco
09-06-2009, 21:52
Salve a tutti, me ne sono appena andato dal forum di ubuntu perchè qualche genialoide voleva che fossi l'UNICO ad osservare delle regole stupide che nessuno ha mai osservato......comunque, pace all'anima dei "geni", ora sono qui.

Ho un piccolo problema, ho reinstallato windows e zio Bill ha fatto in modo che window sovrapponesse il suo bootloader a quello di linux. Dopo diversi tentativi e girovagare fra forum e guide varie sono riuscito a risolvere il problema installando il grub da knoppix. Ora però il grub non mi vede windows, qualcuno sa aiutarmi?

francofait
09-06-2009, 22:01
Originariamente inviato da agostino.pinco
Salve a tutti, me ne sono appena andato dal forum di ubuntu perchè qualche genialoide voleva che fossi l'UNICO ad osservare delle regole stupide che nessuno ha mai osservato......comunque, pace all'anima dei "geni", ora sono qui.

Ho un piccolo problema, ho reinstallato windows e zio Bill ha fatto in modo che window sovrapponesse il suo bootloader a quello di linux. Dopo diversi tentativi e girovagare fra forum e guide varie sono riuscito a risolvere il problema installando il grub da knoppix. Ora però il grub non mi vede windows, qualcuno sa aiutarmi?

edita il file /boot/grub/menu.lst e controlla la sezione relativa al boot di windows

title windows
rootnoverify (hdx,x)
chainloader +1
makeactive
x,x sono rispettivamente il driver e la partizione d'avvio del SO
per cui supposto che sia l' haddisk primario come di norma e la prima partizione dovrebbe essere così

title windows
rootnoverify (hd0,0)
chainloader +1
makeactiive

agostino.pinco
09-06-2009, 22:16
dando quel comando questo è quello che mi esce

# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1


io ho XPpro, non lo vedo nella stringa, significa qualcosa?

francofait
09-06-2009, 22:36
Originariamente inviato da agostino.pinco
dando quel comando questo è quello che mi esce

# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1


io ho XPpro, non lo vedo nella stringa, significa qualcosa?

embè che ti sembrano quelle 4 righe commentate ? un cesto di insalata ?
Togli i cancelletti di commento e vedrai che al riavvio funziona:

title Windows 95/98/NT/2000
root (hd0,0)
makeactive
chainloader +1

title può assumere qualunque nome
per comodità e pure ordine riducilo a

title Windows XP Professional

agostino.pinco
09-06-2009, 22:58
ci sono in tutti i righi del testo quei cancelletti, li tolgo comunque?

agostino.pinco
09-06-2009, 23:08
tolti, FUNZIONAA!
mi è comparsa una nuova riga nel boot con quello che ho scritto nel file modificato,
grazie 100000

Loading