PDA

Visualizza la versione completa : Problemi con Grub


Kmutil
27-06-2009, 09:19
Salve a tutti, volevo portare alla vostra attenzione un problema che ho avuto nell'installazione dell'ultima distro di Ubuntu.

Premessa: ho 3 HD Sata (120,160,500 GB) su quello da 120 gb ho installato windows xp professional.

Il fatto: Ho provato ad installare ubuntu sul disco fisso da 160 GB, l'installazione Ŕ andata a buon fine ma quando ho riavviato mi Ŕ partito windows e di grub non se ne vista traccia, ho formattato la partizione con ubuntu, pulito il MBR con la console di ripristino di windows ed ho provato a reinstallare linux, prima della fine dell'installazione ho specificato di installare grub sull'hd che conteneva windows, pensando che si trattasse di un problema di avvio degli HD, qualcosa Ŕ cambiato, riavviando dopo qualche secondo mi appare in alto a sinistra la scritta GRUB ma non esce altro a schermo ed il pc non va avanti. ho riaggiustato il MBR (altrimenti non potevo neanche avviare windows) ora vorrei sapere da chi magari ci Ŕ passato o che sÓ dove sbaglio, come posso fare per installare linux su un hd diverso da quello di windows. Grazie !

sacarde
27-06-2009, 11:30
ma hai installato sul'MBR del primo disco letto ?

oppure avvia il disco che lo contiene dal boot-menu del bios

Kmutil
29-06-2009, 09:48
Ciao Sarcade,
grazie per esserti interessato al mio problema, cercher˛ di scendere ancora di pi¨ nel dettaglio, proprio perche pensavo che grub per partire dovesse essere installato nell' MBR del primo disco letto ho impostato l'installazione affinche lo installasse nel disco rigido da 120 GB (quello che contiene anche windows) come ho giÓ specificato una differenza c'Ŕ stata, una scritta grub Ŕ apparsa in alto a sinistra ma non mi dava le opzioni per l'avvio, da perfetto profano potrei supporre perche la distro di linux era installata su un altro disco fisso, quello da 160 GB, quindi, si nel bios ho settato l'HD da 120 come hard disk letto per primo quindi non credo sia quello il problema.

sacarde
29-06-2009, 10:34
se da grub entri in modalita' comandi (premendo c)

pi assegni la root: root (hd..,..)
carichi: kernel ...con parametri
carichi: initrd .....

poi : boot

Kmutil
29-06-2009, 13:04
Ho provato a fare quello che hai detto. Quando Ŕ apparso in altro a sinistra la scritta:

GRUB _





Ho premuto c ma non Ŕ successo nulla

francofait
29-06-2009, 13:27
Avere dischi separati per i due SO ed andare a sovrascrivere il loader di windows Ŕ puro sadomasochismo , a quel modo ogni volta che devi reinstallare wincozz saluti stupidamente grub.

installa ubuntu facendogli mettere grub sull' mbr della sua unita' , poi da bios inverti l' ordine di avvio.
Quando ti ritroverai a dover reinstallare wincozza sarÓ sufficente disabilitare da bios l' unitÓ ubuntu per reinstallare wincozza senza perdere grub e sopratutto eviti anche le pi¨ remote possibilitÓ che la sovrascrittura del loader di wincozza crei problemi al SO.

sacarde
29-06-2009, 13:32
se ho capito bene

quella scritta indica che c'e' un errore in grub

prova a reinstallarlo

Kmutil
30-06-2009, 08:58
Problema risolto ! Ho installato Grub sul disco fisso che conteneva ubuntu e poi nel bios ho settato le prioritÓ su quel disco ed ora grub parte e funziona tutto bene, ne approfitto per ringraziarvi e per porvi un altro quesito riguardante sempre grub, purtroppo non sono l'unico ad usare il pc e quindi ho necessitÓ di settare in grub windows xp come sistema operativo di default, sapete dirmi, passo passo come configurare grub in questo modo ?

Grazie ancora !

sacarde
30-06-2009, 09:15
http://www.mandrakeitalia.org/modules/newbb/viewtopic.php?topic_id=13949&forum=7

francofait
30-06-2009, 09:17
Originariamente inviato da Kmutil
Problema risolto ! Ho installato Grub sul disco fisso che conteneva ubuntu e poi nel bios ho settato le prioritÓ su quel disco ed ora grub parte e funziona tutto bene, ne approfitto per ringraziarvi e per porvi un altro quesito riguardante sempre grub, purtroppo non sono l'unico ad usare il pc e quindi ho necessitÓ di settare in grub windows xp come sistema operativo di default, sapete dirmi, passo passo come configurare grub in questo modo ?

Grazie ancora !

nel menu.lst di ubuntu assegni alla variabile 'default' il valore corrispondente alla posizione di windows nellla list -1 (-1 perchŔ grub usa lanotazione esadecimale , quindi lo 0 ha valore significativo)

Oppure sposti la sezione windows mettendola per prima.

Loading