PDA

Visualizza la versione completa : Come risolvo questo problema di apt?


taylorella
04-07-2009, 18:25
Ho aggiunto al sources.list due repository per Firefox 3.5 ma ora non mi servono più e li ho cancellati. Siccome era richiesta una chiave GPG l'ho aggiunta secondo le istruzioni, ma deve essere andato male qualcosa, perchè mi dà sempre questo errore:

Errore GPG: http://ppa.launchpad.net jaunty Release: Le seguenti firme non sono state verificate perché la chiave pubblica non è disponibile: NO_PUBKEY EF4186FE247510BEImpossibile ottenere http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/dists/jaunty/maindeb-src/binary-i386/Packages 404 Not Found
Impossibile ottenere http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/dists/jaunty/http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/binary-i386/Packages 404 Not Found
Impossibile ottenere http://ppa.launchpad.net/ubuntu-mozilla-daily/ppa/ubuntu/dists/jaunty/jaunty/binary-i386/Packages 404 Not Found
Impossibile scaricare alcune file di indice, essi verranno ignorati, oppure si useranno quelli precedenti.

Come faccio a mettere a posto sta cosa?

francofait
04-07-2009, 18:43
Controlla meglio il sources.list , stando a quel che rispone apt le repositry sono sempre lì .

apt-get -f clean
apt-get update

Qualunque modifica al sorcio vuole anche l' update

taylorella
06-07-2009, 17:44
Bon, risolto: nel sources.list c'erano due indirizzi che nel copia-incolla erano stati scritti di seguito e non uno sotto l'altro, mentre per la chiave GPG sono andato in internet a cercare il sito in cui era specificata e l'ho aggiunta di nuovo. Nello specifico sono i repository necessari a installare Firefox 3.5, che in effetti ho installato qualche giorno fa, dopodichè mi è comparso l'errore. :ciauz:

Loading