PDA

Visualizza la versione completa : trasfrimento dati in LAN molto lento


Kilin
20-08-2009, 13:10
ciao a tutti...

ho da poco installato con successo una rete LAN cablata in casa. Ho tre pc, due desktop e un notebook, così connessi:

switch hub
- hag fastweb
- pc1
- pc2
- powerline ethernet -> pc3

ho provato a trasferire da un pc al pc3, quello collegato tramite powerline, un file di quasi 6.7Gb, e ci sta mettendo un'oretta. Come mai così lento? Da taskmanager sto monitorando il trasferimento, e vedo che l'utilizzo della rete varia tra il 10% e il 25% di picco.. perchè diamine non sfrutta tutta la banda?

premetto che le powerline sono da 200Mbps, e la qualità della connessione powerline è buona (l'utility che la monitora mi da 2 pallini su 3, che corrisponde a una velocità raggiungibile superiore a 100Mbps, quindi non è qui il problema, credo)

vi ringrazio

edit: ho dimenticato qualche dettaglio:
- su entrambe le macchine c'è win xp pro sp3.
- su una c'è sygate personal firewall + avast antivirus, sull'altra comodo firewall + avira antivir
ciao!

xenox75
20-08-2009, 16:34
il PC3 è collegato a powerline ethernet, ma l'altro PC è collegato allo switch hub ?
Se si e lo "switch hub" arriva max a 100 Mbit/s la velocità viene automaticamente limitata alla velocità più bassa in questo caso tra 200 Mb/s e 100 Mb/s i dati viaggiano a 100 Mb/s.

Altra cosa da tenere in considerazione la velocità è in Mega Bit e non Mega byte, per avere la velocità in MegaByte devi dividere per 8..

Per cui 100/8 = 12,5 MB/s velocità in ogni caso Massima Teorica, ma NON REALE...

Le velocità reali sono sempre minori, dovuto a distanza, disturbi segnale, velocità compressione decompressione dati, ecc...

Se per trasferire 6,7 GB di dati ci impiega 1 ora significa che sta viaggiando a circa 2 MB/S ossia 16 Mbit/s

Considerando il tipo di impianto adottato e la non perfetta purezza del segnale è un valore che ci potrebbe stare...
anche perchè hai parecchi programmi che possono rallentare il trasferiento dei dati...

Kilin
20-08-2009, 16:51
il PC3 è collegato a powerline ethernet, ma l'altro PC è collegato allo switch hub ?
Se si e lo "switch hub" arriva max a 100 Mbit/s la velocità viene automaticamente limitata alla velocità più bassa in questo caso tra 200 Mb/s e 100 Mb/s i dati viaggiano a 100 Mb/s.

si, tutto è connesso allo switch hub, non speravo infatti di andare a 200Mbps, ma almeno a 100 si..



Le velocità reali sono sempre minori, dovuto a distanza, disturbi segnale, velocità compressione decompressione dati, ecc...

acc, da 100Mbps a 16Mbps però ce n'è di differenza! Il passaggio da velocità teorica a reale è così tanto distruttivo?


Considerando il tipo di impianto adottato e la non perfetta purezza del segnale è un valore che ci potrebbe stare...

a cosa ti riferisci? alle powerline? allo switch? hai consigli per migliorare l'impianto?ad esempio se eliminassi lo switch hub, e collegassi il tutto così:

hag fastweb
-> pc1
-> pc2
-> powerline -> pc3

avrei speranze di migliorare?


anche perchè hai parecchi programmi che possono rallentare il trasferiento dei dati...

ti riferisci ad antivirus e firewall sulle due macchine? d'altra parte su quel fronte non penso si possa migliorare, quei prog ci vogliono su entrambi i lati..


grazie dell'aiuto

xenox75
20-08-2009, 17:17
Secondo me quelo che ti fa calare le prestazioni è il "powerline ethernet ".
non lo conosco bene, ma se non erro è l'apparecchietto che si connette alla presa di corrente per collegare in rete il PC sfruttanto l'impianto elettrico...

molti di questi apparecchietti segnano come velocità 10/200 Mbit, molto dipende anche da come è fatto l'impianto elettrico...

Altra cosa se gli altri 2 PC hanno schede che vanno a 1000 Mbit è meglio avere uno switch 100/1000 piuttosto che uno da 100 che ti limità la velocità massima...

se però i Pc hanno schede a 100 Mbit in tal caso va bene anche uno switch da 100 perch come detto vale il valore minore...

Per testare la rete attuale fai una prova...

1° Copia il file da 6.7 GB dal PC 1 al PC2 o viceversa e vedi effettivamente il tempo che impiega...

2° Fai la stessa prova disattivando il firewall su entrambe i PC e vedi se migliora o resta più o meno uguale...

Se non vuoi correre rischi durante la prova statta hag fastweb così non vai su internet... Puoi o spengerlo o semplicemente basta staccare il cavo...

Secondo me già con la 1° prova dovresti notare dei tempi più bassi...
Se così è il Problema è powerline...

Fammi sapere l'esito della prova...

ciao

Kilin
20-08-2009, 17:47
appena riesco faccio tutte le prove del caso...

ho già provato disabilitando i firewall e mi pare andasse più o meno alla stessa maniera. Mi rimane da provare senza passare dalle powerline.. Comunque come ti ho detto c'è una utility insieme alle powerline che ti dice la qualità della connessione tra due powerline collegate a due prese diverse (le fa "parlare" e ne trae informazioni sulla qualità, quindi tiene di conto dell'effettivo impianto elettrico), e questa prova mi da sempre 2-3 pallini su 3. Sul libretto delle istruzioni c'è scritto che basta un pallino per connessioni dati, mentre 3 pallini servono per dispositivi che fanno streaming video ecc. Quindi dovrei essere apposto per quanto riguarda le powerline. Proverò comunque.

per il resto, solo un pc ha la scheda da 1000mbit, quindi o cambio scheda di rete agli altri oppure mi tengo la 100mbit.. Intanto ho cambiato configurazione, ho tolto l'hub, e tutti vanno diretti nell'hag fastweb, magari miglioro qualcosa ... è pur sempe un passaggio in meno. Se poi mi dovesse riservire lo collego a una porta dell'hag, ma almeno con questa configurazione ho dei pc con la connessione diretta all'hag, come era fin'ora tutti passavano per lo switch..

grazie ancora, appena provo ti faccio sapere!

Loading