PDA

Visualizza la versione completa : http://mio_ip non mi vedo...


gasmor
04-10-2009, 09:01
buona domenica a tutti.

Vi espongo il mio problema: ho una rete in cui c' un mac un windows e il router.
So che l'ip del mac 192.168.1.35, l'ip del windows 192.168.1.33 e l'ip del router 192.168.1.1

L'ip del del windows ottenuto automaticamente. Lo leggo tramite ipconfig ed infatti corretto perch gli ho aperto delle porte dal firewall e funziona tutto perfettamente.

Nel windows c' installato Easyphp mentre per il mac uso il server incluso nel suo sistema operativo Leopard.

Ora se dal windows apro l'indirizzo:
http://127.0.0.1/ -> mi compare correttamente l'home page di easyphp;
http://192.168.1.35/ -> vedo l'home-page del server mac;
http://192.168.1.33 -> ERRORE CARICAMENTO PAGINA

perch?
ho provato anche:
http://192.168.1.33:80 ma ottengo lo stesso errore

mroghy
04-10-2009, 17:09
Prova anche http://192.168.1.33:8080

gasmor
04-10-2009, 20:31
Originariamente inviato da mroghy
Prova anche http://192.168.1.33:8080

non funziona :bh:

neroux
04-10-2009, 20:50
Secondo me, l'Apache su Windows sar configurato di ascoltare solo su localhost (127.0.0.1) e non su tutti gli indirizzi. Dovresti controlla la configurazione di Apache (httpd.conf), in particolare la direttiva "Listen".

Puoi contrallarlo aprendo un command prompt e richiamando "netstat -na", ci dovrebbe essere questa riga


TCP 0.0.0.0:80 0.0.0.0:0 LISTENING
ma probabilmente ci sar solo questa


TCP 127.0.0.1:80 0.0.0.0:0 LISTENING

gasmor
04-10-2009, 21:50
si, c' solo questa riga:


TCP 127.0.0.1:80 0.0.0.0:0 LISTENING

adesso l'ho modificata in 0.0.0.0:80

grazie :ciauz:

neroux
04-10-2009, 21:57
EDIT: Perfetto :ciauz:

Loading