PDA

Visualizza la versione completa : Configurazione xfree86 no screens found


pauldianno85
05-10-2009, 04:36
Ciao, ho configurato xserver-xfree86 con debian woody

dpkg-reconfigure xserver-xfree86, ho impostato tutti i parametri del mio vecchissimo portatile, indicando che ha 88 tasti ho impostato un mouse seriale logitech collegato e ho impostato la scheda video una vga 24 bit, ho impostato un monitor lcd con risoluzione 640x480 60hz, non imposto i dri gli dico no
faccio partire starx e mi dice no screens foun come errore, le ho provate tutte ma non riesco a capire perché non mi trova nessuno schermo, fatemi sapere qualcosa, ciao e grazie :fighet:

sacarde
05-10-2009, 10:04
c'e' :

xf86config (XF86Config)
o
xf86cfg

?

jaso
05-10-2009, 11:48
Prova a mettere Lenny ugualmente.

Z0rn
05-10-2009, 12:22
Sarebbe utile qualche files di configurazione (tipo xorg.conf, per dirne uno) e qualche log (tipo Xorg.0.log, sempre per fare un esempio)...
Ma magari allegali, invece di postarli qui, che poi finiscono nei motori di ricerca inutilmente

pauldianno85
05-10-2009, 14:28
Allora lenny non mi si installa, appena faccio partire l'installazione si blocca ad un processo e ripete all'infinito quello, il cd è masterizzato correttamente perché l'ho installato in diversi computer.

Il file è XF86Config-4

il file log XF86 dice no screens found, già l'ho controllato, secondo me ci sono problemi nel configurare la scheda e video e a sua volte il monitor

pauldianno85
05-10-2009, 14:31
In giro per la rete ho trovato questa risoluzione di problemi, non ho ancora provato la modifica manuale delle dimensioni dello schermo,


6.18.10. Risoluzione dei problemi

*

Verificare i file /var/log/XFree86.log e ~/.xsession-errors per avere degli indizi.
*

Modificare /etc/X11/XF86Config-4 e ricercare la riga Option "UseFBDev" "true" e modificare "true" in "false".
*

Se non funziona ancora, modificare Driver= parametro di configurazione.
*

Quando si è sicuri che l'opzione del driver è corretta, ma esso non funziona ancora, provare aggiustamenti ai valori di HorizSync e VertRefresh. Si provi con questi: HorizSync 30-80 VertRefresh 40-90.
*

Siate sicuri di avere qualche versione di window manager installata, apt-get install icewm dovrebbe bastare.
*

dpkg-reconfigure xserver-xfree86 dovrebbe aprire un configuratore interattivo, lo si provi.

Z0rn
05-10-2009, 15:53
Guarda, magari non ne viene fuori nulla comunque, ma di norma per risolvere i problemi con un device sono necessari (anche se non sempre sufficienti) tre gruppi di informazioni:
1) Identificativo preciso del device e dettagli sul S.O. installato (kernel, sottosistema grafico, nello specifico)
2) File di configurazione
3) File di log
Senza questi dati non devi rivolgerti qui, devi rivolgerti al forum dei maghi e medium italiani.

gio14
05-10-2009, 20:47
Credo che devi sapere con esattezza il tipo di scheda video e di conseguenza scrivere il nome del driver in XF86Config-4 (al limite prova il driver "vesa")

pauldianno85
06-10-2009, 02:33
Allora il sistema è una debian 3.0 r2 woody con kernel 2.2.20 su un portatile del 96 o 97 che ha 5 giga di hard disk un processore celeron 400 con una scheda audio cirrus logic e mi ha riconosciuto anche la scheda pcmcia con discover, ma non riesco a capire che scheda video ha, ho provato con vesa ma non ci sono speranze forse dovrei provare a fare installazione vanilla, oppure dovrò smontare il portatile per sapere che scheda video è, però è anche vero che i driver gli ho provati tutti emi sembra strano che mi da sempre lo stesso errore

pauldianno85
06-10-2009, 04:39
Allora l'errore l'ho risolto, praticamente mettendo questo parametro manualmente pci:1:0:0 nella configurazione di XFreeConfig-4 e impostando come scheda video vesa senza indicare quanti mega ha la scheda e impostando una risoluzione di 640x480 60 hz dando l'ok digitando startx parte la grafica e parte anche all'avvio del sistema, il problema cruciale rimane il touchpad del portatile, in questo momento sto usando un mouse seriale e lo riconosce perfettamente, però voglio usare il touchpad chi mi da una mano ad impostarlo :fighet:

Loading