PDA

Visualizza la versione completa : installare firmware-iwlwif non-free


celbro
16-10-2009, 20:21
Salve a tutti,
sto provando a far funzionare la scheda wireless PRO/Wireless 4965 sul mio portatile con debian lenny. Leggendo sulla debian-wiki, il primo passo dovrebbe essere quello di installare il firmware "firmware-iwlwifi" che perņ č non-free e quindi non č presente di default nell'elenco dei pacchetti di debian.
Per inserire pacchetti non-free dovrei modificare il file /etc/apt/source.list, ma se l'aggiungo all'elenco dei cd-rom mi compare il seguete errore:


Impossibile ottenere cdrom://[Debian GNU/Linux testing _Lenny_ - Official Snapshot i386 DVD Binary-1 20090126-03:57]/dists/lenny/non-free/binary-i386/Packages Si prega di usare apt-cdrom per far riconoscere questo CD-ROM da APT. apt-get update non puņ essere usato per aggiungere nuovi CD-ROM


cosa dovrei fare?

francofait
16-10-2009, 21:03
Originariamente inviato da celbro
Salve a tutti,
sto provando a far funzionare la scheda wireless PRO/Wireless 4965 sul mio portatile con debian lenny. Leggendo sulla debian-wiki, il primo passo dovrebbe essere quello di installare il firmware "firmware-iwlwifi" che perņ č non-free e quindi non č presente di default nell'elenco dei pacchetti di debian.
Per inserire pacchetti non-free dovrei modificare il file /etc/apt/source.list, ma se l'aggiungo all'elenco dei cd-rom mi compare il seguete errore:


Impossibile ottenere cdrom://[Debian GNU/Linux testing _Lenny_ - Official Snapshot i386 DVD Binary-1 20090126-03:57]/dists/lenny/non-free/binary-i386/Packages Si prega di usare apt-cdrom per far riconoscere questo CD-ROM da APT. apt-get update non puņ essere usato per aggiungere nuovi CD-ROM


cosa dovrei fare?

devi disativare i supporto cdrom nel sorces.list
aggiungere le repositry mancanti
fare un primo aggiornamento globale del SO poi installare i pacchetti di cui hai bisogno.

In breve dopo aver aggiornato il sources.list:

per installare nuovi driver nel kernel inoltre devi avere presente installati sia il compilatore che l' headers del tuo kernel in uso

apt-get install build-essential per installare il compilatore con le librerie essenziali
l' header del kernel in usolo lo trovi e lo installi tramite il Synapic, la gui di supporto alla gestione dei pacchetti.



da console con privilegi root acquisiti:

apt-get update && apt-get -f dist-upgrade

finito l' upgrade installi i pacchetti di cui hai bisogno.

apt-get install namepackage

celbro
16-10-2009, 21:09
ma fare "apt-get -f dist-upgrade" non potrebbe darmi problemi?

francofait
16-10-2009, 21:11
Originariamente inviato da celbro
ma fare "apt-get -f dist-upgrade" non potrebbe darmi problemi?

No anzi potresti averne a non farlo , le repositry vengono tenute aggiornate costantemente , anche se in lenny gli aggiornamenti sono limitati a bugfix e sicurezza.

celbro
16-10-2009, 21:14
ti ringrazio!

Loading