PDA

Visualizza la versione completa : apt-get e problemi di dipendenze


Neptune
09-11-2009, 23:47
Salve a tutti,
stavo provando ad installare pidgin tramite apt-get, ma si Ŕ bloccato a metÓ per dei problemi di dipendenze su alcune librerie (tra qui quelle per il perl).

Adesso ogni volta che provo a dare il comando "apt-get install" per installare qualsivoglia cosa il processo si blocca dicendomi che ci sono dei problemi di dipendenze irrisolte.
Ecco la schermata che mi appare:



root@siduxbox:/home/neptune/Desktop/pidgin-2.6.3# apt-get install kdevelop
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
╚ utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
kdevelop: Dipende: kdelibs4c2a (>= 4:3.5.9) ma non sta per essere installato
Dipende: libapr1 (>= 1.2.7) ma non sta per essere installato
Dipende: libqt3-mt (>= 3:3.3.8b) ma non sta per essere installato
Dipende: libsvn1 (>= 1.4) ma non sta per essere installato
Dipende: kdevelop-data (>= 4:3.5.5-1) ma non sta per essere installato
Dipende: kdebase-bin ma non sta per essere installato
libc6-i686: Predipende: libc6 (= 2.9-20) ma 2.10.1-6 sta per essere installato
perl-modules: Dipende: perl (>= 5.10.1-1) ma 5.10.0-24 sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
root@siduxbox:/home/neptune/Desktop/pidgin-2.6.3# apt-get -f install
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti saranno inoltre installati:
libc6-i686 libperl5.10 perl perl-base
Pacchetti suggeriti:
perl-doc libterm-readline-gnu-perl libterm-readline-perl-perl
I seguenti pacchetti saranno aggiornati:
libc6-i686 libperl5.10 perl perl-base
4 aggiornati, 0 installati, 0 da rimuovere e 514 non aggiornati.
5 non completamente installati o rimossi.
╚ necessario scaricare 0B/6558kB di archivi.
Dopo quest'operazione, verranno liberati 221kB di spazio su disco.
Continuare [S/n]? S
Configuro libc6 (2.10.1-6) ...
Checking for services that may need to be restarted...
Checking init scripts...
invoke-rc.d: action cron is unknown, but proceeding anyway.
invoke-rc.d: unknown initscript, /etc/init.d/-query not found.
dpkg: errore processando libc6 (--configure):
il sottoprocesso installed post-installation script ha restituito un codice di errore 100
Sono occorsi degli errori processando:
libc6
E: Sub-process /usr/bin/dpkg returned an error code (1)


Come faccio ad eliminare questi pacchetti che hanno problemi di dipendneze per ripristinare la situazione iniziale?

Vi ringrazio in anticipo per la disponibilitÓ,
neptune.

bereshit
10-11-2009, 00:43
Provare "apt-get -f install" senza pacchetti

francofait
10-11-2009, 01:26
dpkg: errore processando libc6 (--configure):


dpkg --force-all --configure -a
apt-get -f install

Neptune
10-11-2009, 01:46
Mi vergogno a dirlo ma non avevo pensato a provare l'opzione "--force-all" e dato che era un sistema appena installato ho fatto prima a reinstallarlo da zero.

Ad ogni modo la prossima volta prover˛ come mi avete consigliato. Anche perchŔ in qualche modo dovr˛ installarcelo sopra pidgin (per la serie se non mi si sputtana di nuovo tutto non sono contento :D).

Loading