PDA

Visualizza la versione completa : Problem installazione ruby! Help me


harvin96
24-12-2009, 01:46
Ciao a tutti, sono un progammatore con media esperienza... Ruby mi ha sempre attirato ed è da 1 settimana circa che lo sto studiando, tramite le guide di ruby.html.it
L'altro ieri ho riscontrato un problema che ancora oggi non sono riuscito a risolvere... se potete aiutatemi.

Se non ho capito bene il linguaggio da usare x fare un sito in ruby è il ruby on rails, per questo mi sono affidato alla guida Ruby on rails di html.it (http://ruby.html.it/guide/leggi/123/guida-ruby-on-rails/); Nella lezione n 3, spiega come installare ruby su windows, ho seguito esattamente quello che mi indicava la guida, ma non ci sono riuscito, qui vi elenco quello che ho fatto (ditemi se ho sbagliato qualcosa):

1. ho scaricato il One-Click Installer (old) da http://rubyforge.org/frs/?group_id=167&release_id=41273.
2. L'ho avviato e l'ho installato
3. ho eseguito il prompt dei comandi come amministratore (connesso a internet) gli ho scritto: "gem install rails -y", ma mi ha dato errore "ERROR: While executing gem ... (Gem::GemNotFoundException)
Could not find rails (> 0) in any repository"
--IL TUTTO FATTO SU WINDOWS 7 ULTIMATE--
Questi sono i passaggi che ho fatto seguendo la 3 lezione della guida ( lezione --->http://ruby.html.it/guide/lezione/3088/installazione-su-windows/)


Cosa ho sbagliato??? :confused: :bhò:
per favore aiutatemi xkè sto impazzendo!!!

weppos
28-12-2009, 11:54
In realtà è il contrario.
Ruby è il linguaggio, Rails è il framework scritto in Ruby.

Non scaricare l'installer vecchio, è possibile che contenga il percorso sbagliato al repository o una versione vecchia di RubyGems.
Ti consiglio di scaricare il nuovo RubyInstaller, possibilmente 1.9.1.

http://rubyforge.org/frs/download.php/66872/rubyinstaller-1.9.1-p243-rc1.exe

harvin96
28-12-2009, 20:30
Grazie tante, adesso provo ad andare avanti con la guida!! riuscirò a fare un sito in ruby???
se dovessi riscontrare problemi vi ridisturberò!


Grazie

Loading