PDA

Visualizza la versione completa : info installare ruby / Haml / SASS /compass


morfina
11-01-2010, 16:25
Salve,
per motivi di lavoro mi trovo a dover installare ed imparare ad utilizzare SASS (http://sass-lang.com/). I problemi iniziano proprio dall'inizio (che più inizio non si può). Anzitutto non ho capito cosa devo installare tra i programmi elencati sotto per utilizzare SASS.

ho scaricato:
ruby-1.9.1-p376
haml-2.2.16
compass

Se qualcuno mi sapesse dare qualche informazione utile e pratica (ad esempio come installare haml) mi sarebbe di molto aiuto. anche un link ad un tutorial (anche in inglese) è ben accetto.

grazie.

weppos
01-02-2010, 12:15
Devi installare ruby e rubygems, la procedura varia a seconda del sistema operativo.
Ad installazione completata, è sufficiente installare la libreria haml poiché sass è parte di haml.

L'installazione avviene via RubyGems. Apri la console (terminal o prompt a seconda del sistema operativo) e digita il comando


gem install haml

Beo75
10-02-2010, 16:51
posso consigliarti un tutorial video di peepcode (http://peepcode.com/products/haml-and-sass) davvero ben fatto e chiaro anche se in inglese. costa 9 dollari ma li vale tutti.

saluti

Loading