PDA

Visualizza la versione completa : RubyGem version error: rack(1.0.0 not ~> 1.0.1)


Sgurbat
21-02-2010, 13:07
Sto cercando di usare Rails 2.3.5 su Ubuntu con JRuby e GlassFish come Server ma cercando di far partire il mio progetto ottengo questo errore:


RubyGem version error: rack(1.0.0 not ~> 1.0.1)

Premetto che rack era già installata come gemma nella versione 1.0.1 eppure.

Ora ho fatto un update e mi risultano due gemme.


rack (1.1.0, 1.0.1)

Ma il problema non sembra risolto.

Suggerimenti?

Grazie.

Sgurbat
21-02-2010, 14:33
Ho notato che la cosa capita solo usando JRuby, se utilizzo la MRI e Mongrel il problema sparisce.

weppos
22-02-2010, 09:51
Sicuro che la Gem sia presente sotto JRuby?
In genere se usi sia JRuby sia Ruby le Gem sono in due percorsi diversi, ogni piattaforma ha le sue.

Sgurbat
22-02-2010, 10:49
Originariamente inviato da weppos
Sicuro che la Gem sia presente sotto JRuby?
In genere se usi sia JRuby sia Ruby le Gem sono in due percorsi diversi, ogni piattaforma ha le sue.

Uhm, guarda non saprei nel senso che JRuby me lo sono ritrovato avendo scaricato NetBeans 6.8

Nello specifico la piattaforma, quando creo il progetto, mi indica Built-in JRuby 1.4.

weppos
22-02-2010, 11:00
Se non ti serve cambialo ed imposta il tuo interprete.

Sgurbat
22-02-2010, 11:21
Originariamente inviato da weppos
Se non ti serve cambialo ed imposta il tuo interprete.

No adesso non mi serve nel senso che utilizzo l'interprete in C di default però volevo cercare di capire il problema per risolverlo nel caso possa poi venire utile sviluppare in JRuby per sfruttare le librerie di Java.

weppos
22-02-2010, 11:27
Originariamente inviato da Sgurbat
No adesso non mi serve nel senso che utilizzo l'interprete in C di default però volevo cercare di capire il problema per risolverlo nel caso possa poi venire utile sviluppare in JRuby per sfruttare le librerie di Java.

Se mai ti servirà JRuby, tanto vale installarlo e buttare via la versione in bundle con NetBeans.

Il problema è quello che ti dicevo. Tu hai installato la Gem ma per quanto riguarda Ruby standard. Ogni piattaforma ha i suoi percorsi e le sue Gem, quindi JRuby non vede le Gem installate su Ruby standard e viceversa. Devi installarla anche su JRuby, in questo caso usando NEtBeans.

FiOrEbAt
18-05-2010, 13:17
ah.. tasto destro sul progetto, imposta la configurazione, personalizza, manage built-in jruby 1.40, gem manager, settings, fetch all versions, new gems, rack (in minuscolo) e prendi la giusta versione..


facile no?



un'attratto da .net mvc
Fiorebat

weppos
18-05-2010, 13:27
Originariamente inviato da FiOrEbAt
ah.. tasto destro sul progetto, imposta la configurazione, personalizza, manage built-in jruby 1.40, gem manager, settings, fetch all versions, new gems, rack (in minuscolo) e prendi la giusta versione..


facile no?



un'attratto da .net mvc
Fiorebat

Nessuno ti obbliga ad usare jruby, tanto meno netbeans.

Loading