PDA

Visualizza la versione completa : gdb su ubuntu 10.04 beta


MrX87
01-04-2010, 16:43
Ciao a tutti sto cercando di imparare qualcosa del debugger di linux nella shell...per la precisione gdb! ho letto che per avviare il debug basta dare questo comando:

gdb -q ./programma
a questo punto però già mi compare un messaggio strano:

Reading symbols from /home/thecrow/debugger/firstprg...(no debugging symbols found)...done.
e poi provando a mettere qualche breakpoint con il comando break seguito dal numero della riga del programma dove si vuole piazzare il breakpoint, non me lo fa insierire e mi da questo messaggio:

No symbol table is loaded. Use the "file" command.
E infine anche quando vado a fare uso del disassemblatore, e do il comando per disassemblare secondo la sintassi intel:

(gdb) set dis intel
Ambiguous set command "dis intel": disable-randomization, disassemble-next-line, disassembly-flavor, disconnected-tracing...

Non vorrei che questi problemi siano dovuti al fatto che ho ancora installato una versione beta e quindi mancano alcune impostazioni finali, o se sono io che non so come funziona bene gdb! in ogni caso se ci fosse qualcuno che sa qualcosa in più mi farebbe piacere se mi dicesse dove sto sbagliando!
Grazie mille
Ciao

sacarde
01-04-2010, 21:07
letto?

http://wiki.ubuntu-it.org/Programmazione/GnuDebugger

MrX87
12-04-2010, 22:33
ciao, ho letto il link che mi è stato postato, e ho fatto un pò di prove, ma con risultati scarsi....alcuni comandi non vanno come dovrebbero, come per esempio il comando "list" che mi da errore:

No symbol table is loaded. Use the "file" command.
e sempre il comando break che non mi permette di posizionare un breakpoint su una riga a mio piacimento del programma! funziona solo "break main"!! Non vorrei che questi problemi sono dovuti al fatto che utilizzo una versione non definitiva...sono con la 10.04 beta...ma tra poco dovrebbe uscire la definitiva...o non so se è già uscita la RC!!
se qualcuno sa dirmi qualcosa in più lo ringrazio!!

mxa
13-04-2010, 02:59
Ma tu quando hai compilato con gcc hai usato il flag -g? o -ggdb insomma.

sebaldar
13-04-2010, 17:51
prova ad installarti kdbg

simo_us
19-04-2010, 01:45
usa il flag -g con gcc e basta.

Loading