PDA

Visualizza la versione completa : UBUNTU 9.10 non vede scheda video su notebook


ivy_76
09-06-2010, 20:46
Ciao

ho installato la versione come da oggetto su una macchina virtuale con XP Pro come sistema operativo guest.

La scheda video integrata (intel 82852) non viene riconosciuta e la risoluzione dello schermo Ŕ sempre 800x600 nonostante io provi a cambiarla manualmente. Inoltre non Ŕ possibile neanche modificare la frequenza di aggiornamento dello schermo.

Come posso risolvere il mio problema ? So pochissimo di ubuntu. .. abbiate pazienza.

sacarde
10-06-2010, 09:23
non ho capito quale e' host e quale guest

e su che emulatore


p.s.
quale scheda viene emulata?

ivy_76
10-06-2010, 09:30
Ho un notebook HP-compaq nx9030 con windows XP come sistema operativo sul quale ho installato la Virtual Machine Workstation. Ho una macchina virtuale con sopra Ubuntu 9.10 per cui Ubuntu Ŕ virtuale mentre Windows Ŕ reale :-)

La scheda video del portatile che viene correttamente riconosciuta da Windows Ŕ una Intel 82852 mentre Ubuntu non la vede e per quel motivo non mi fa cambiare nÚ la risoluzione dello schermo (che resta sempre 800*600) ne la frequenza di aggiornamento (che resta sempre sui 0 HZ !!)

sacarde
10-06-2010, 09:44
ma usi vmware ?
o
virtualpc
o
virtualbox


secondo l'emulatore... emula una sua scheda

lo vedi da:

lspci | grep VGA



p.s.
per riconfigurare:

sudo dpkg-reconfigure -phigh xserver-xorg

ivy_76
10-06-2010, 11:44
VMWARE

Ok ho capito cosa devo fare per˛ ho ancora un dubbio. Supponiamo (dato che ora sono in ufficio e non ho il mio computer per le mani ) che restituisca qualcosa del tipo :



00:02.0 VGA compatible controller: Intel Corporation 82852 Chipset Graphics Controller


come faccio a impostare correttamente le impostazioni ?

Il comando che mi hai indicato tu:



sudo dpkg-reconfigure -phigh xserver-xorg


lo fa in automatico ?

sacarde
10-06-2010, 11:58
riconfigura Xorg, cioe' /etc/X11/xorg.conf


quello che chiede interattivamente:

http://www.freesoftwaremagazine.com/columns/how_to_fix_your_computers_graphics_with_dpkg-reconfigure



p.s.
oppure puoi ricrearlo (xorg.conf) con il comando:
Xorg -configure

ivy_76
10-06-2010, 12:08
ok ho capito, stasera provo.

Grazie

ivy_76
10-06-2010, 19:25
Rieccomi qui

allora il comando


lspci | grep VGA

ha dato questo risultato



00:0f.0 VGA compatible controller: VMware SVGA II Adapter


visto che lui vede una scheda virtuale come faccio a farla funzionare correttamente ? Come ho detto non so nulla di Linux per cui seguimi passo passo per favore.

Dalle impostazioni della macchina virtuale vedo che il monitor indicato Ŕ "use host setting for monitors" per cui dovrebbe prenderlo da solo, no ?

sacarde
10-06-2010, 20:08
Originariamente inviato da sacarde
riconfigura Xorg, cioe' /etc/X11/xorg.conf


quello che chiede interattivamente:

http://www.freesoftwaremagazine.com/columns/how_to_fix_your_computers_graphics_with_dpkg-reconfigure



p.s.
oppure puoi ricrearlo (xorg.conf) con il comando:
Xorg -configure

sono questi due i modi per configurare X

p.s.
Xorg -configure
devi darlo da root senza X avviato

francofait
10-06-2010, 20:10
Originariamente inviato da ivy_76
Rieccomi qui

allora il comando


lspci | grep VGA

ha dato questo risultato



00:0f.0 VGA compatible controller: VMware SVGA II Adapter


visto che lui vede una scheda virtuale come faccio a farla funzionare correttamente ? Come ho detto non so nulla di Linux per cui seguimi passo passo per favore.

Dalle impostazioni della macchina virtuale vedo che il monitor indicato Ŕ "use host setting for monitors" per cui dovrebbe prenderlo da solo, no ?

il monitor non pu˛ essere emulato , Ŕ fuori dubbio che vede quello che hai davanti ai tuoi occhi, ad essere emulata e la scheda video e dal responso di grep viene emulata una semplice svga senza accelerazione grafica e risoluzione max 800x600
vmware per˛ dovrebbe permettere anche il riconoscimento della scheda grafica reale ,( metto il condizionale perch˛ non ne ho mai fatto uso , preferisco la semplicitÓ di virtualbox ) sicura di averlo configurato bene?

Loading