PDA

Visualizza la versione completa : squeeze 64bit: firefox non si avvia


magnet_80
16-06-2010, 09:37
ho scaricato firefox e messo in /usr/lib


root@andrea:/usr/lib/firefox# ln -s /usr/lib/firefox/firefox /usr/bin/firefox
root@andrea:/usr/lib/firefox# firefox
/usr/lib/firefox/run-mozilla.sh: 399: /usr/lib/firefox/firefox-bin: not found
root@andrea:/usr/lib/firefox# cd/
root@andrea:~# firefox
/usr/lib/firefox/run-mozilla.sh: 399: /usr/lib/firefox/firefox-bin: not found

qualche idea su tale problema? non mi pare che ci sia la versione a 64 bit.
qui: http://ubuntuforums.org/showthread.php?t=542315 (risale al 2007) sembra che a firefox non piaccia i 64bit

francofait
16-06-2010, 09:56
Stai vivendo la notte dei tempi , firefox a 64bit e regolarmente disponibile sia per le versioni 64bit di Ubuntu che di debia, mandriva, fedora ecc.
Usa le repositry giuste .

magnet_80
16-06-2010, 10:24
quale sarebbe il repo? io ho scaricato il tar da mozilla, scompattato e messo in /usr/lib

magnet_80
16-06-2010, 12:40
al momento mi devo accontentare della 3.7apre6 che è l'unica che mi funziona, prelevata da
ftp://ftp.mozilla.org/pub/firefox/nightly/latest-mozilla-central/
ha qualche problema con flash, però rispetto a iceweasel funziona un pò meglio

francofait
16-06-2010, 12:59
ftp://ftp.mepis.com/mepis/pool/main/f/firefox/firefox_3.5.6-2_amd64.deb

lo trovi anche nelle repositri di kanotix 2010

La ricerca con google funziona sempre.

bereshit
16-06-2010, 14:18
su debian ff si chiama iceweasel non è necessario sporcare il sistema con altri repo

magnet_80
16-06-2010, 15:10
@bareshit: so che c'è iceweasel, è instalalto ma non lo uso perchè con i386 mi dava problemi: visualizzazione errata del sito del corriere, non sentivo la radio on line, non visualizzava correttamente i video e altro.
così, sempre con i386, avevo scaricato ff e tutto funzionava.
2 giorni fa, ho rifatto il pc e sono passato dal i386 a amd64. il problema e che ff non funziona (vedere errore sopra), ice ha sempre i problemi con corriere e altri siti, così cercavo il modo di far funzionare ff 3.6.3, ma ho visto che è impossibile. per ora (dato che sono in ufficio), ho dovuto installare la versione 3.7apre6, che risolve il problema della visualizzazione del corriere, ma va in crash con il plugin flash. stasera proverò con il file deb che franco mi ha elencato

magnet_80
16-06-2010, 22:23
ho risolto, in maniera parziale installando ia32-libs ia32-libs-gtk. così facendo ff funziona.
rimane il problema di flashpalyer, scaricato da adobe, ma installato con dpkg -i --force-architecture.
non riesco a capire se flash funziona o no
@franco: se parto dal file deb che mi hai postato tu, riesco poi dal menù di ff aiuto->controlla aggiornamenti a passare alla 3.6.3?
EDIT: grande cavolata che ho fatto con dpkg. flash non funziona. provato a reinstall flashplugin-nonfree ma i filmati su youtube non si vedono.
con synaptic mi trova solo flashplugin-nonfree e non install_flash_player_10_linux.deb (installato con dpkg -i). come faccio a trovare e rimuovere quest'ultimo?

magnet_80
17-06-2010, 15:20
@ franco
oggi ho provato il file deb che mi hai postato. funziona, ma rimane il problema di flash: infatti, la visualizzazione del corriere (la barra a dx con le ultime notizie è vuota) e di youtube (il riquadro dei filmati è nero e non viene caricato nulla) non funziona.
ho installato flashpalyer-nonfree, ma la situazione non cambia.
rimane solamente da scaricare flash dal sito di adobe, in versione .deb.
però non so se va bene per i 64bit
hai già avuto problemi del genere con i 64 bit?

Loading