PDA

Visualizza la versione completa : Avvio Linux From Scratch


EDX
23-06-2010, 01:02
Salve a tutti.

Recentemente sul mio portatile con giÓ Windows Vista e Slackware in dual-boot, ho deciso di compilarmi e installarmi la mia Linux From Scratch. Il tutto si Ŕ svolto senza problemi, pacchetti compilati Ŕ installati. Poi da Slackware, in cui ho installato LILO, il bootloader di cui faccio uso, ho aggiornato /etc/lilo.conf e ho riavviato.
Al riavvio, mi si presenta subito un problema del tipo:


VFS - Cannot open root device 806 ... Kernel Panic - Not Syncing: VFS: Unable to mount root...

Googlando un po riesco a risolverlo, cosý come in seguito risolvo un problema legato al file /etc/fstab, che con fsck attivo sulla partizione root bloccava il tutto. Tutto risolto sembrerebbe, ma in seguito ho dovuto ricompilare il kernel(v. 2.6.32.8) per aggiungere features mancanti di cruciale importanza, quali la modalitÓ VESA all'avvio, e molte altre. Ricompilo il Kernel senza problemi, riaggiorno LILO con la nuova immagine, lasciando il resto intatto, ma mi si presenta un problema che non riesco a risolvere, ovvero:


mount: mounting /dev/sda6 on /mnt failed: no such device.

Dopo questo messaggio si apre una conole di emergenza, con cui noto che comunque il device /dev/sda6 esiste, ma quando vado a montarlo manualmente con "mount /dev/sda6 /mnt", ricevo l'errore: "Invalid argument".

Ringrazio in anticipo chi mi pu˛ dare una mano.

sacarde
23-06-2010, 17:46
sei sicuro


sd.. e non hd..

EDX
23-06-2010, 18:37
Sisi, sul portatile il disco Ŕ di tipo SCSI, quindi sd...

sacarde
23-06-2010, 20:32
che vedi con:


dmesg | grep sd

e

dmesg | grep hd

EDX
23-06-2010, 23:06
Allora:

dmesg | grep sd:

sd 0:0:0:0: [sda] 488397168 512-byte logical blocks: (250 GB/232 GiB)
sd 0:0:0:0: [sda] Write protect is off
sd 0:0:0:0: [sda] Mode sense: 00 3A 00 00
sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
sda: sda1 sda2 sda3 < sda5 sda 6 > sda4
sd 0:0:0:0: [sda] Attached SCSI disk

dmesg | grep hd:

hda: Tsst corp CD/DVDW TS-L632M, ATAPI CD/DVD-ROM device
hda: host max PIO4 wanted PIO255(auto-tune) selected PIO4
hda: UDMA/33 mode selected
ide-cd: hda: ATAPI 24X DVD-ROM DVD-R/RAM CD-R/RW drive, 2048kB cache

sacarde
24-06-2010, 09:25
ma hai problemi solo sulla sda6 o su tutte ?

EDX
24-06-2010, 14:56
No, Ŕ solo LFS che non riesce a montare sda6, Slackware monta tranquillamente sda5, Windows funziona tranquillamente su sda1. Ho anche fatto dei controlli con fsck ma risulta ok.

sacarde
24-06-2010, 16:55
ha un filesystem particolare?


hai il modulo di quel filesystem?

cat /proc/filesystems

EDX
25-06-2010, 16:43
Intanto grazie per le risposte, l'output di cat /proc/filesystems Ŕ


nodev sysfs
nodev rootfs
nodev bdev
nodev proc
nodev tmpfs
nodev debugfs
nodev securityfs
nodev sockfs
nodev usbfs
nodev pipefs
nodev anon_indefs
nodev inotifyfs
nodev devpts
nodev ramfs
romfs
nodev mqueque

sacarde
25-06-2010, 17:05
ma che filesystem ha?



p.s.

fdisk -l /dev/sda

Loading