PDA

Visualizza la versione completa : debian: dopo blackout fstab corrotta?


magnet_80
03-08-2010, 22:55
č saltata la luce e in fase di boot mi segnala un errore sul sda2 (la root)
in effetti, fstab mi segnala un errore che posto sotto.
da kubuntu live, ho fatto un fsck su /dev/sda2 e mi ha corretto degli errori.
riavviato il pc, perņ mi continua a segnalare errore.
qui fstab


# /etc/fstab: static file system information.
#
# Use 'vol_id --uuid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sda2 during installation
UUID=5aa3d3a4-55e5-44d4-9b23-5df3a85ffa3a / ext4 errors=remount-ro 0 1
# /boot was on /dev/sda1 during installation
UUID=e81bd7f7-0df6-4c40-aaba-90158b296053 /boot ext4 defaults 0 2
# /home was on /dev/sda3 during installation
UUID=8f797cc2-24bf-49bc-9d8c-057779524e05 /home ext4 defaults 0 2
# swap was on /dev/sda4 during installation
UUID=acfec5ac-e31a-43f2-a527-4b5e45d3b733 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0 0
/dev/scd1 /media/cdrom1 udf,iso9660 user,noauto 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto 0 0
tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0

francofait
03-08-2010, 23:00
Ripeti il comando fin che risolve il ripristino del fs completo

magnet_80
03-08-2010, 23:46
continuo a farlo da kubuntu.
per cui, in teoria, fsck dovrebbe sistemare fstab su /dev/sdaXX?

edit: l'ho eseguito 3 volte per disco. il pc parte in maniera corretta, ma in fase di boot, mi segnala un errore di un "/ missing at end of line"
non riesco perņ a trovare i messaggi relativi alla fase di boot (provato con dmesg ma non elenca l'errore in oggetto), in modo tale da poterlo postare in maniera corretta.
grazie

magnet_80
04-08-2010, 22:38
sono riuscito a filmare il boot.
ecco l'errore che da:
mounting local filesystem... [mntemt]: warning: no final newline at the etc/fstab
fstab č postato sopra.
il pc funziona, perņ vorrei sapere se il warning crea qualche problema

sacarde
06-08-2010, 17:50
http://ubuntuforums.org/showthread.php?t=33879

magnet_80
06-08-2010, 19:11
ciņ, basta che dņ un invio e il problema si risolve??
stasera provo!!!

Loading