PDA

Visualizza la versione completa : [Squeeze] Problemi con ZOPE2


IsmaeleII
24-08-2010, 13:21
Ciao.

Nell'azienda in cui lavoro mi hanno posto questo quesito informatico :

a quali problemi potremmo andare incontro installando Zope2 su Debian(Squeeze) ?
sicurezza?
aggiornamento?



Grazie per la collaborazione.




Ismaele

bereshit
24-08-2010, 14:21
debian stable fornisce pieno supporto agli aggiornamenti di sicurezza

ma puoi articolare meglio la domanda?

IsmaeleII
24-08-2010, 14:49
Originariamente inviato da bereshit
debian stable fornisce pieno supporto agli aggiornamenti di sicurezza

ma puoi articolare meglio la domanda?


Se l'azienda continua ad utilizzare Zope2 (versione obsoleta di ZOPE...che nel frattempo e' arrivata a ZOPE3) con 'Python 2.4', quali problemi di integrazione/sicurezza potrebbero esserci installando questo ambiente su Squeeze ?



Grazie

bereshit
24-08-2010, 16:09
squeeze ancora in testing, quindi instarla in ambiente di produzione gi di per s un problema di sicurezza

poi in squeeze non c zope2 (che c'era ancora in lenny)

perci te lo devi pacchettizzare te, e devi vedere di risolvere eventuali dipendenze che non ci sono nei repo ufficiali,

ovviamente facendo cos sei te che devi seguire i rilasci di patch etc e ricompilare ogni volta etc

(a meno che non trovi dei repo gi pronti , ma se non sono ufficiali non li userei)

per python non si ragiona in maniera differente, se richiede il 2.4 , in squeeze non c , devi vedere nei backport ufficiali, o ricompilartelo con tutte le dipendenze da te

seocndo me un grosso lavoro, e come ogni grosso lavoro devi farlo bene, perch se no la questione sicurezza ti saluta

tieni conto che pi customizzi un server con pacchetti "tuoi" pi dev stargli dietro a patch per ogni dipendenza installata etc

secondo me fate prima a portare tutto sotto zope 3

Loading