PDA

Visualizza la versione completa : problema con hdd esterno


dario2588
28-08-2010, 11:16
ciao a tutti, non so perch ma quando inserisco il disco esterno non me lo rileva (me lo faceva pure con fedora e pensavo che mettendo opensuse risolvessi il problema) l'hard disk esterno un packardbell da 650Gb non autoalimentato, qualcuno sa come risolvere??

gargamella08
28-08-2010, 13:39
Originariamente inviato da dario2588
ciao a tutti, non so perch ma quando inserisco il disco esterno non me lo rileva (me lo faceva pure con fedora e pensavo che mettendo opensuse risolvessi il problema) l'hard disk esterno un packardbell da 650Gb non autoalimentato, qualcuno sa come risolvere??

Apri un terminale, scrivi:

tail -n 0 -f /var/log/messages e prova a collegare.
Copia l'output.

dario2588
29-08-2010, 02:19
facendo quello che mi hai detto mi viene questo:


Aug 29 02:18:33 linux-r6wf kernel: [ 298.100107] usb 2-2: new full speed USB device using uhci_hcd and address 2
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275074] usb 2-2: New USB device found, idVendor=152d, idProduct=2339
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275083] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275089] usb 2-2: Product: USB to ATA/ATAPI Bridge
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275093] usb 2-2: Manufacturer: JMicron
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275097] usb 2-2: SerialNumber: DA2677108FFF
Aug 29 02:18:33 linux-r6wf kernel: [ 298.323492] Initializing USB Mass Storage driver...
Aug 29 02:18:33 linux-r6wf kernel: [ 298.396809] scsi2 : usb-storage 2-2:1.0
Aug 29 02:18:33 linux-r6wf kernel: [ 298.397150] usbcore: registered new interface driver usb-storage
Aug 29 02:18:33 linux-r6wf kernel: [ 298.397157] USB Mass Storage support registered.
Aug 29 02:18:34 linux-r6wf kernel: [ 299.417185] scsi 2:0:0:0: Direct-Access WDC WD64 00AAKS-00A7B0 PQ: 0 ANSI: 2 CCS
Aug 29 02:18:34 linux-r6wf kernel: [ 299.417554] sd 2:0:0:0: Attached scsi generic sg2 type 0
Aug 29 02:18:34 linux-r6wf kernel: [ 299.450159] sd 2:0:0:0: [sdb] 1250263728 512-byte logical blocks: (640 GB/596 GiB)
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452934] sd 2:0:0:0: [sdb] Write Protect is off
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452944] sd 2:0:0:0: [sdb] Mode Sense: 00 38 00 00
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452949] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.461118] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.461131] sdb: sdb1
Aug 29 02:18:34 linux-r6wf kernel: [ 299.490936] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.490947] sd 2:0:0:0: [sdb] Attached SCSI disk

francofait
29-08-2010, 10:53
Originariamente inviato da dario2588
facendo quello che mi hai detto mi viene questo:


Aug 29 02:18:33 linux-r6wf kernel: [ 298.100107] usb 2-2: new full speed USB device using uhci_hcd and address 2
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275074] usb 2-2: New USB device found, idVendor=152d, idProduct=2339
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275083] usb 2-2: New USB device strings: Mfr=1, Product=2, SerialNumber=5
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275089] usb 2-2: Product: USB to ATA/ATAPI Bridge
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275093] usb 2-2: Manufacturer: JMicron
Aug 29 02:18:33 linux-r6wf kernel: [ 298.275097] usb 2-2: SerialNumber: DA2677108FFF
Aug 29 02:18:33 linux-r6wf kernel: [ 298.323492] Initializing USB Mass Storage driver...
Aug 29 02:18:33 linux-r6wf kernel: [ 298.396809] scsi2 : usb-storage 2-2:1.0
Aug 29 02:18:33 linux-r6wf kernel: [ 298.397150] usbcore: registered new interface driver usb-storage
Aug 29 02:18:33 linux-r6wf kernel: [ 298.397157] USB Mass Storage support registered.
Aug 29 02:18:34 linux-r6wf kernel: [ 299.417185] scsi 2:0:0:0: Direct-Access WDC WD64 00AAKS-00A7B0 PQ: 0 ANSI: 2 CCS
Aug 29 02:18:34 linux-r6wf kernel: [ 299.417554] sd 2:0:0:0: Attached scsi generic sg2 type 0
Aug 29 02:18:34 linux-r6wf kernel: [ 299.450159] sd 2:0:0:0: [sdb] 1250263728 512-byte logical blocks: (640 GB/596 GiB)
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452934] sd 2:0:0:0: [sdb] Write Protect is off
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452944] sd 2:0:0:0: [sdb] Mode Sense: 00 38 00 00
Aug 29 02:18:34 linux-r6wf kernel: [ 299.452949] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.461118] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.461131] sdb: sdb1
Aug 29 02:18:34 linux-r6wf kernel: [ 299.490936] sd 2:0:0:0: [sdb] Assuming drive cache: write through
Aug 29 02:18:34 linux-r6wf kernel: [ 299.490947] sd 2:0:0:0: [sdb] Attached SCSI disk

Sembra che l' unit dal kernel sia gestita senza errori.

Se regolarmente formattata la dovresti avere disponibile in /media/disk

dario2588
29-08-2010, 11:19
c' una preferenza di formattazione??? fat, fat32 exfat...
se vado su /media la cartella vuota
e un'altra cosa, se vado su dispositivi rimovibili in impostazioni di sistema, il disco me lo vede:
ci sono i segni di spunta su :
abilita montaggio automatico dei supporti rimovibili
monta tutti i supporti rimovibili all'accesso
monta automaticamente i supporti rimovibili al collegamento

e poi nella finestra sotto c' la spunta a:
montaggio automatico all'accesso
montaggio automatico al collegamento


se stacco il disco esterno, su dispositivi scollegati mi compare un dispositivo che ha l'icona di un punto interrogativo... bho, che macello...

gargamella08
29-08-2010, 11:51
Originariamente inviato da dario2588
c' una preferenza di formattazione??? fat, fat32 exfat...


Linux gestisce fat e ntfs, ma non exfat. Come formattato?


Originariamente inviato da dario2588
se vado su /media la cartella vuota
e un'altra cosa, se vado su dispositivi rimovibili in impostazioni di sistema, il disco me lo vede:
ci sono i segni di spunta su :
abilita montaggio automatico dei supporti rimovibili
monta tutti i supporti rimovibili all'accesso
monta automaticamente i supporti rimovibili al collegamento

e poi nella finestra sotto c' la spunta a:
montaggio automatico all'accesso
montaggio automatico al collegamento


Se sono gi attivi dovrebbe montarlo... prova a collegarlo
e a dare un:



su
parted -l /dev/sdb


E riporta l'output.

Ciao

gargamella08
29-08-2010, 11:52
Mi correggo, meglio se usi fdisk in luogo di parted, stessa sintassi.

Ciao

dario2588
30-08-2010, 02:03
scusami, ma sono uno alle prime armi... che cos' fdisk??? (e che vuol dire in luogo di parted???) come si usa??

gargamella08
30-08-2010, 02:07
Originariamente inviato da dario2588
scusami, ma sono uno alle prime armi... che cos' fdisk??? (e che vuol dire in luogo di parted???) come si usa??

Scrivi semplicemente i seguenti comandi in un terminale e posta
l'output:


su
fdisk -l /dev/sdb


Ciao

cacao74
30-08-2010, 07:57
la butto li: il filesystem e' cifrato ?

Loading