PDA

Visualizza la versione completa : ssh accesso non riconosciuto


lillop
09-09-2010, 10:57
Salve

Ho installato in un pc in rete la debian, appena dopo installata, ho lanciato il comando "apt-get install ssh" in modo tale da poterci smanettare da remoto.
Quando provo a collegarmi dall'altro pc con putty e provo a inserire la login mi dice:
login as: inserisco login di un utente semplice, premo invio e mi da
Sent username "nome_mio_utente"
nome_mio_utente@indirizzoip_locale password:

Se inserisco la password non mi fa accedere.
Credo che debbo disabilitare le chiavi di ssh

Apro il config di ssh e metto no alla voce
"PubkeyAuthentication no"

Riavvio ssh e cmq non funziona :(

sacarde
09-09-2010, 11:16
ma :

openssh-server

cel'hai?

lillop
09-09-2010, 11:20
credo che l'abbia fatto quando ho lanciato il comando apt-get install ssh
perchè se faccio apt-get install openssh-server
mi dice pacchetto gia installato

sacarde
09-09-2010, 11:46
il servizio e' attivo?


http://guide.debianizzati.org/index.php/OpenSSH:_configurazione_di_base

lillop
09-09-2010, 11:57
Credo di averlo configurato correttamente tramite la guida che mi hai segnalato, ma continua a non andare :(



# Package generated configuration file
# See the sshd(8) manpage for details

# What ports, IPs and protocols we listen for
Port 22
# Use these options to restrict which interfaces/protocols sshd will bind to
#ListenAddress ::
#ListenAddress 0.0.0.0
Protocol 2
# HostKeys for protocol version 2
#HostKey /etc/ssh/ssh_host_rsa_key
#HostKey /etc/ssh/ssh_host_dsa_key
#Privilege Separation is turned on for security
UsePrivilegeSeparation yes

# Lifetime and size of ephemeral version 1 server key
KeyRegenerationInterval 3600
ServerKeyBits 768

# Logging
SyslogFacility AUTH
LogLevel INFO

# Authentication:
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes

RSAAuthentication no
PubkeyAuthentication no
#AuthorizedKeysFile %h/.ssh/authorized_keys

# Don't read the user's ~/.rhosts and ~/.shosts files
IgnoreRhosts yes
# For this to work you will also need host keys in /etc/ssh_known_hosts
RhostsRSAAuthentication no
# similar for protocol version 2
HostbasedAuthentication no
# Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
IgnoreUserKnownHosts yes

# To enable empty passwords, change to yes (NOT RECOMMENDED)
PermitEmptyPasswords no

# Change to yes to enable challenge-response passwords (beware issues with
# some PAM modules and threads)
ChallengeResponseAuthentication no

# Change to no to disable tunnelled clear text passwords
PasswordAuthentication yes

# Kerberos options
#KerberosAuthentication no
#KerberosGetAFSToken no
#KerberosOrLocalPasswd yes
#KerberosTicketCleanup yes

# GSSAPI options
#GSSAPIAuthentication no
#GSSAPICleanupCredentials yes

X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
#UseLogin no

#MaxStartups 10:30:60
#Banner /etc/issue.net

# Allow client to pass locale environment variables
AcceptEnv LANG LC_*

Subsystem sftp /usr/lib/openssh/sftp-server

UsePAM yes

sacarde
09-09-2010, 12:22
dal log che vedi?

/var/log/......



p.s.
se provi a conneterti da linux su linux ?

ssh utente@<ip-linux>

lillop
09-09-2010, 14:57
risolto!
Il problema era altro.
Grazie

Loading