PDA

Visualizza la versione completa : [UBUNTU] cambiare hostname


tiro1997
21-10-2010, 19:34
Buonasera,
uso una versione server di Ubuntu 9.10...

dovrei cambiare l' hostname ma dopo aver fatto le opportune modifiche ai file avrei bisogno di riavviare il servizio per rendere
operativo il nuovo hostname...

leggo sui tutorial che dovrei trovare il classico script di start|stop|restart in /etc/init.d ma non ho nulla di simile...

Come posso fare per rendere effettiva la modifica evitando il reboot della macchina?

Grazie mille...

charlieroot
21-10-2010, 20:00
ciao, effettivamente il comando sarebbe
sudo /etc/init.d/networking restart , però magari per qualche motivo sulla tua macchina lo script potrebbe, per qualche motivo, essere stato spostato da qualche altra parte.
locate networking ti dà qualche suggerimento?
( Occhio che su Ubuntu non so, ma su fedora e openbsd locate richiede id fare un update del database, controlla magari con )
man locate. Spero di esserti stato utile

tiro1997
21-10-2010, 20:32
Grazie per la risposta...

no, non si tratta del servizio networking (hai ragione non l'ho specificato)

le guide consigliano di riavviare /etc/init.d/hostname...
ma io non trovo nulla di simile

Grazie ancora

charlieroot
21-10-2010, 20:38
sempre per tentativi... cosa succede se provi a dare banalmente

sudo hostname restart
?

psykopear
21-10-2010, 21:18
Che file hai modificato per impostare l'host?

sacarde
22-10-2010, 10:09
ci dovrebbe essere il comando: hostname

maje
22-10-2010, 11:35
io ho fatto così:

- sudo gedit /etc/hostname (ho cambiato l'hostname)
- sudo gedit /etc/hosts (ho modificato il file sostituendo al vecchio hostname il nuovo)
- riavvio del sistema

:ciauz:

cacao74
23-10-2010, 01:48
indizio:


ls /proc/sys/kernel/

e vedi se c'e' qualcosa che attira la tua attenzione!
ovviamente NON devi riavviare per rendere attive le modifiche...

cacao74
23-10-2010, 01:50
Originariamente inviato da cacao74
indizio:


ls /proc/sys/kernel/

e vedi se c'e' qualcosa che attira la tua attenzione!
ovviamente NON devi riavviare per rendere attive le modifiche...
[edit]
sacarde aveva gia' dato una risposta esatta!
[edit]

Loading