PDA

Visualizza la versione completa : Virtualbox e rete virtuale


BeBO
02-11-2010, 19:51
Ciao a tutti,
ho un piccolo problema che non riesco a risolvere...
Utilizzo per lavoro una macchina Linux (Ubuntu 10.04) e ho virtualizzata una macchina XP (ho necessitÓ a volte di utilizzare SQLServer).

Solitamente utilizzavo la macchina virtuale configurata con un bridge sulla eth0 dell'host e assegnato un indirizzo relativo alla rete locale sulla quale si interfaccia pure l'host.

In realtÓ non ho bisogno che la macchina windows sia accessibile dall'esterno e preferirei poterla raggiungere solo dall'host ed eventualmente mascherarla verso l'esterno.
Ho allora tirato su un bridge (br0), una scheda di rete virtuale (tap0) e configurato il tutto.

tunctl -t tap0 -u NOMEUTENTE
ip link set up dev tap0
brctl addbr br0
brctl addif br0 tap0
ip link set up dev br0
ip addr add 10.1.1.1/24 dev br0
ip route add 10.1.1.0/24 dev br0

Fatto questo tutto funziona a meraviglia... fino a quando non mi collego con il cavo alla rete aziendale!
Appena collegato alla rete le 2 macchine (host e guest) non si vedono pi¨, e se dalla macchina host faccio un ping di 10.1.1.2 ricevo un "ping: sendmsg: Operation not permitted" mentre ricomincia a pingare non appena ristacco il cavo.

Mi viene da pensare che una volta collegato alla rete aziendale, la ricerca dell'indirizzo 10.1.1.2 passi per qualche apparato di rete prima ancora di interrogare la rete virtuale.
La cosa invece non succede se sono collegato sulla mia rete domestica tramite interfaccia wi-fi (wlan0).

Preciso che l'ip della rete aziendale Ŕ un ip statico e che il collegamento o scollegamento del cavo non scatena alcun evento sulla macchina host.

Credo di essermi perso qualcosa... cosa?

ooops... che firma vecchia che ho :shy:

Loading