PDA

Visualizza la versione completa : Installare "php5-cli" su un Ubuntu 8.10.


Grejo
20-11-2010, 13:36
Ciao. :ciauz:
Su un mio Ubuntu 8.10 di test vorrei installare il pacchetto "php5-cli" per provare l'esecuzione di script PHP da shell.
Il problema è che però non riesco a scaricare tale pacchetto perchè mi compare sempre il seguente errore:



test@server-test-01:~$ sudo apt-get install php5-cli
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
php5-cli: Depends: php5-common (= 5.2.4-2ubuntu5.12) but 5.2.6-2ubuntu4.6 is to be installed
E: Broken packages


Qualche idea/soluzione? Io non riesco ad uscire da questo problema, e non vorrei aggiornare la mia macchina di test.
Ciao.
Grejo

cacao74
20-11-2010, 15:32
prova:


# apt-get update
# apt-get install php5-cli

se non usi root, anteponi "sudo" ai suddetti comandi

vortex87
20-11-2010, 17:25
Potrebbe aiutare anche un aggiornamento dei pacchetti già installati, con apt-get upgrade.

toraz
20-11-2010, 20:54
Non vorrei spararla grossa ma a me risulta che i repository per la versione 8.10 non esistano nemmeno piu`...

bereshit
21-11-2010, 03:01
eh si non essendo più supportata dovrebbero aver rimosso i repo

però non so se fanno come debian che hanno un server per le old stable, tenuto per ragioni di memoria, ma non credo

francofait
21-11-2010, 09:43
Originariamente inviato da bereshit
eh si non essendo più supportata dovrebbero aver rimosso i repo

però non so se fanno come debian che hanno un server per le old stable, tenuto per ragioni di memoria, ma non credo

ci sono sempre , i repositri ci sono tutti, ci sono sempre pure le iso per i supporti dvd , quelle non più supportate non sono semplicemente più oggetto di aggiornamenti..

Loading