PDA

Visualizza la versione completa : Touchpad non funziona con Ubuntu 10.10


snieco
14-12-2010, 17:43
Ciao a tutti,
dopo aver fuso il mio amato Dell XPS M1530 :incupito: :incupito:

ho acquistato un nuovo portatile, in particolare il Sony Vaio VPCEB3M1E (valli a capire questi con sti codici prodotto...), che mi è arrivato venerdi scorso.
Ho provato il portatile con Win 7 e tutto funziona a dovere, ieri mi sono messo ad installare Ubuntu 10.10 (mi piace come SO, lo uso da un po', in più ora mi serve per la tesi perchè stiamo sviluppando una applicazione per Android, quindi ci installo Java, Eclipse, Tomcat ecc ecc) e il touchpad non vuole saperne di funzionare! Io per comodità utilizzo molto di più il mouse esterno, ma in caso di necessità quando non sono a casa, uso il touchpad.

Eseguendo
$ cat /proc/bus/input/devices
mi compariva "Macintosh mouse button emulation" (lo riconosce come touchpad mac?) mentre in win lo riconosce come touchpad Alps...

Ora dopo una giornata di varie prove per far funzionare sto benedetto touchpad non va ancora... Sapete dirmi come si può far funzionare????

Grazie a tutti

Alessio

gio14
15-12-2010, 23:53
prova vedere se hai installato il pacchetto "xserver-xorg-input" poi dai un occhiata a /etcX11/xorg.conf (questo è il mio xorg.conf dai un occhio alla parte riguardante il mouse e il touchpad)


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/X11R6/lib/X11/fonts/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/X11R6/lib/X11/fonts/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/X11R6/lib/X11/fonts/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/X11R6/lib/X11/fonts/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
FontPath "/usr/X11R6/lib/X11/fonts/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection


Section "Module"
Load "i2c"
Load "bitmap"
Load "ddc"
# Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "it"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
# Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "Device"
Identifier "nVidia Corporation NVIDIA Default Card"
Option "NoLogo" "True"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Monitor Generico"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
DisplaySize 331.8 207.4
EndSection

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NVIDIA Default Card"
Monitor "Monitor Generico"
DefaultDepth 24
SubSection "Display"
Depth 1
Modes "1200x800" "1152x864" "1152x768" "1024x768"
EndSubSection
SubSection "Display"
Depth 4
Modes "1200x800" "1152x864" "1152x768" "1024x768"
EndSubSection
SubSection "Display"
Depth 8
Modes "1200x800" "1152x864" "1152x768" "1024x768"
EndSubSection
SubSection "Display"
Depth 15
Modes "1200x800" "1152x864" "1152x768" "1024x768"
EndSubSection
SubSection "Display"
Depth 16
Modes "1680x1050" "1600x1024" "1440x900" "1400x1050"
EndSubSection
SubSection "Display"
Depth 24
Modes "1680x1050" "1600x1024" "1440x900" "1400x1050"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "Synaptics Touchpad"
EndSection

Section "ServerFlags"
Option "AutoAddDevices" "False"
Option "AllowEmptyInput" "False"
EndSection

Section "DRI"
Mode 0666
EndSection

snieco
16-12-2010, 09:07
Originariamente inviato da gio14
prova vedere se hai installato il pacchetto "xserver-xorg-input" poi dai un occhiata a /etcX11/xorg.conf (questo è il mio xorg.conf dai un occhio alla parte riguardante il mouse e il touchpad)

Si sono installati i pacchetti
- xserver-xorg-input-all
- xserver-xorg-input-wacom
- xserver-xorg-input-wmmouse
- xserver-xorg-input-mouse
- xserver-xorg-input-evdev
- xserver-xorg-input-synaptics

Il mio xorg.conf è simile al tuo:


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "ServerLayout"
Identifier "aticonfig Layout"
Screen 0 "aticonfig-Screen[0]-0" 0 0
InputDevice "Synaptics Touchpad"
EndSection

Section "Module"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ExplorerPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizScrollDelta" "0"
EndSection

Section "InputClass"
Identifier "enable synaptics SHMConfig"
MatchDevicePath "/dev/input/event1"
MatchIsTouchpad "yes"
Option "SHMConfig" "on"
EndSection

Section "Monitor"
Identifier "aticonfig-Monitor[0]-0"
Option "VendorName" "ATI Proprietary Driver"
Option "ModelName" "Generic Autodetecting Monitor"
Option "DPMS" "true"
EndSection

Section "Device"
Identifier "aticonfig-Device[0]-0"
Driver "fglrx"
BusID "PCI:1:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device "aticonfig-Device[0]-0"
Monitor "aticonfig-Monitor[0]-0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
EndSubSection
EndSection
in /dev/input sono presenti: by-id, by-path, event0, event1, event2, event3, event4, event5, event6, event7, mice, mouse0, mouse1...

Ciao e grazie!

sacarde
16-12-2010, 17:59
simile?

http://westhoffswelt.de/blog/0041_sony_vaio_x_ubuntu_installation_experience.ht ml

snieco
16-12-2010, 20:12
Originariamente inviato da sacarde
simile?

http://westhoffswelt.de/blog/0041_sony_vaio_x_ubuntu_installation_experience.ht ml

Purtroppo no... Avevo già visto quell'url... Almeno il touchpad di quel Sony funziona, non gli funziona il multitouch, ma almeno qualcosa funzia... A me la freccina non si muove manco a pagarla!!! :bhò:

zucchino
06-01-2011, 12:12
Ciao,
anche io avevo lo stesso problema su un Sony Vaio VPCEB3J1E/BQ

ho risolto seguendo questo link: http://ubuntuforums.org/showthread.php?t=1565548&highlight=vaio+touch+pad

e cioé:
1. modificando il file /etc/default/grub includendo la riga GRUB_CMDLINE_LINUX="i8042.nopnp"
2. lanciando il comando: sudo update-grub
3. riavviando il pc

snieco
06-01-2011, 14:17
WOW, provato ed effettivamente funziona!!! Avevo già provato ad aggiungere la riga con i8042.nopnp da qualche parte seguendo qualche altra guida, ma non aveva funzionato!

Grazie mille!!

Alessio

Loading