PDA

Visualizza la versione completa : USB mouse bloccato


ricman
22-01-2011, 02:18
Salve... premetto subito che non sono un esperto...

Ubuntu 10...

Mi si "bloccato" il cursore del mouse. Adesso sono su un altro pc con controllo remoto...
Mi si blocc l'altro giorno... riavviai e tutto ok...
Adesso me lo ha rifatto... ma al riavvio rimasto fermo. Tutto funziona (tastiera, rete, audio, programmi...).
Se attacco una pennina usb non la legge. Sembra quasi che sia "guasto il driver dell'usb" (dico "driver" perch il mouse accende il laser e le pennine i led...).

In rete ho letto di provare i vari "sudo modprobe ..." ma non cambia nulla...

Mi date una mano?

sacarde
22-01-2011, 09:11
- prova a cambiare porta usb
- avviando con il cdlive funziona ?
- che vedi con: dmesg | grep mouse
- guarda se in /var/log/Xorg.0.log hai degli errori "EE"

matroblinuxcpu
22-01-2011, 12:37
Succedeva anche a me. Il mio problema era quello che il mouse andava in conflitto con la stampante. Io ho risolto collegandolo alla porta PS/2. Se non disponi di quella porta, prova un'altra porta USB...

ricman
22-01-2011, 13:29
Non so se una coincidenza ma per ben due volte il mouse si bloccato quando ho provato a collegare un hd esterno usb.
Ora dopo l'ennesimo riavvio ripartito.

Il mio mouse solo usb e non so se in giro per casa ho ancora un adattare... varrebbe la pena provare...

ricman
22-01-2011, 13:31
Originariamente inviato da sacarde
1- prova a cambiare porta usb
2- avviando con il cdlive funziona ?
3- che vedi con: dmesg | grep mouse
4- guarda se in /var/log/Xorg.0.log hai degli errori "EE"

1) non cambia nulla
2) non ho provato...
3) mi dice:

dmesg | grep mouse
[ 0.264604] input: Macintosh mouse button emulation as /devices/virtual/input/input2
[ 0.320967] mice: PS/2 mouse device common for all mice

4) non ci sono errori EE in quel file

sacarde
22-01-2011, 13:54
hai fatto degli aggiornamenti?


- dentro /etc/X11/xorg.conf
nella sezione mouse:

...
Section "InputDevice"
Identifier "USB Mouse"
Driver "mouse"
Option "Device" "/dev/input/mice"
Option "SendCoreEvents" "true"
Option "Protocol" "IMPS/2"
Option "ZAxisMapping" "4 5"
Option "Buttons" "5"
EndSection
...


che valori hai?

francofait
22-01-2011, 14:16
Per la cronaca a me successo con gli aggiornamenti di alcuni giorni fa che includevano la revisione .24 del kernel , mi rimaneva bloccata pure la tastiera usb , non risolveva misteriosamente neppure il riavvio con il kernel .22 ; con il rilascio della revisione .25 ed i nuovi aggiornamenti tornato a funzionare tutto da se
Non vorrei che il problema fosse lo stesso .
Sacarde
Xorg.conf in ubuntu da tempo che non c' pi .

sacarde
22-01-2011, 20:56
@francofait
si, ho visto
ma non ho capito come riconfigurare..
esempio in questo caso:

http://forum.html.it/forum/showthread.php?s=&threadid=1442837

Loading