PDA

Visualizza la versione completa : Accesso a Windows tramite LIVE CD Linux


cencia
08-02-2011, 10:27
Ciao a tutti
mi piacerebbe capire come mai con molte distribuzioni Linux LIVE (penso a Knoppix, Kanotix)
è molto semplice accedere al Sistema Operativo Ospitante (nel mio caso W7)
e invece con BACKTRACK o AUDITOR COLLECTION mi risulta cosi difficile trova l'Hard DISK sottostante.

fstab?
ma come?
strano perchè dovrebbe farlo in automatico

accetto suggerimenti al riguardo...

:)

sacarde
08-02-2011, 17:35
se il sistema riconosce l'HD lo vedi da:

dmesg | grep sd
o
dmesg | grep hd

elencandoti anche le partizioni trovate

fdisk -l

magari il mount va fatto a mano

cencia
08-02-2011, 21:35
mount hda ntfs?

cosa dovrei montare....

hai la sintassi corretta?

:)

sacarde
08-02-2011, 21:43
http://linux.collectiontricks.it/wiki/Lettura_e_scrittura_partizioni_NTFS

cencia
09-02-2011, 08:23
GRAZIE
:unz:

cencia
09-02-2011, 16:11
Originariamente inviato da sacarde
http://linux.collectiontricks.it/wiki/Lettura_e_scrittura_partizioni_NTFS

porta pazienza un ultima cosa:

con fdisk -l mi si visualizza solo questa parte


Disk /dev/hda: 10.2 GB, 10242892800 bytes
255 heads, 63 sectors/track, 1245 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

la parte che dovrebbe esserci windows

Device Boot Start End Blocks Id System
/dev/hda1 * 1 803 6450066 7 HPFS/NTFS

non viene visualizzata.

Ho provato a modificare l' fstab, inserendo la riga:

/dev/hda1 /media/windows ntfs umask=000,defaults,nls=utf8 0 0

e dando il mount:

mount /dev/hda1 /media/windows

ma niente da fare.

ritengo di essere sulla strada giusta ma mi manca ancora qualcosina......

:dhò:

sacarde
09-02-2011, 17:04
ma non lo vedi in "fdisk -l"

o non lo monta nemmeno?


p.s.
dopo eseguito il mount che vedi da:

df -TH

cencia
10-02-2011, 08:14
Originariamente inviato da sacarde
ma non lo vedi in "fdisk -l"

o non lo monta nemmeno?


p.s.
dopo eseguito il mount che vedi da:

df -TH

il muont non riesco a farlo perche mi dice che non esiste:

/dev/hda1

è per quello che sono andato ad inserirlo in fstab,
ma al momento del nuovo mount dice:

'bad line in fstab'

PS in fstab la riga

/dev/hda1 /media/windows ntfs umask=000,defaults,nls=utf8 0 0

l'ho messa in fondo (in pratica è la terza riga)

sacarde
10-02-2011, 08:48
ma quanti dischi hai?

dmesg | grep sd
o
dmesg | grep hd


poi

fdisk -l /dev/...... (quello che trovi)

giasonetux
10-02-2011, 10:35
Ubuntu , knoppixs, e altri hanno installato fuse e ntfs- 3g ecco perchè si accede facilmente a Windows e si modifica ho elimina le cose che vuoi. Se le installi risolvi i problemi di mount e accesso a Win7.

Loading