PDA

Visualizza la versione completa : rete ad hoc


cantuccio
03-04-2011, 14:12
Ciao a tutti,
ho un hard disk multimediale che riesco a collegare al mio pc tramite il modem router della mia rete wireless "alice" (a sua volta collegato via wireless al pc). Il percorso è hard disk-router-pc. Per fare questo imposto sull'hard disk "rete AP" (access point) e lui mi rileva automaticamente la rete wireless "alice" e mi ci si aggancia. Però il trasferimento di un file dal pc all'hard disk è molto lento.
Vorrei provare pertanto a collegare wireless il mio hard disk multimediale direttamente al pc (sono in 2 stanze separate dello stesso appartamento) senza passare dal router che si trova fisicamente lontano da entrambi (appartamento sopra).
Ho provato a creare sul pc con s.o. Vista una nuova rete wireless ad hoc aperta (senza autenticazione) denominandola "giu" e poi impostando sull'hard disk:
tipo di rete: ad hoc
ssid: giu
Autenticazione: aperta
IP Host: ????
Ho provato a mettere l'indirizzo IP del pc che possiede sulla rete "alice" (192 168 1 125) ma non lo vede, ho provato nche 192 168 1 1 ma niente. Come devo fare?
sul pc ho una scheda di rete wireless 11 n pci (quella con le 3 antenne) e l'hard disk ha una chiavina usb wi fi g.
Grazie, Fabiano.

MItaly
03-04-2011, 14:20
Al di là dei problemi che incontri, con il wireless il trasferimento sarà comunque relativamente lento, anche nelle condizioni migliori difficilmente supererai i 13 MB/s (6.5 se la rete è a 54 Mb/s) in trasferimento.

cantuccio
03-04-2011, 19:39
Si, lo so ma sono curioso di vedere la differenza e soprattutto non sopporto l'idea che non mi riesca farla andare !!
Comunque, grazie della risposta.

nelsonblu
06-04-2011, 17:16
Non mi vorrei sbagliare ma stai creando due server e non un server e un client wireless.
Hai deciso che il pc sia la sorgente del segnale. Hai effettuato la procedura di rete ad hoc e hai creato correttamente un SSID senza protezione.

l'hardisk ora deve vedere quel SSID nell'aria come fosse un wireless di un router.
A lui non interessa hoc e non hoc.

cantuccio
18-04-2011, 10:21
Ciao,
grazie per la risposta.
Per tagliare la testa al toro nel frattempo ho deciso di fare una rete LAN e perciò proverò a collegarli in LAN.
Se avessi dei problemi chiederò nuovamente il tuo aiuto, grazie ancora.
Fabiano.

cantuccio
26-04-2011, 08:24
Ciao,
forse me la sono gufata.
Ho fatto una LAN collegando al modem/router Netgear DGN3500 uno switch Netgear GS608 ed a questo un HD Multimediale Verbatim e il mio PC con scheda Gigabit Netgear GA311.
Le connessioni sono: Gigabit fra PC e switch, Ethernet fra HD e switch e Gigabit fra modem/router e switch (anche se la vede come Ethernet in quanto ho invertito tutti i cavi sui 2 spinotti mettendo il marrone sul 1° anzichè sull'8, ecc.., rimedierò quanto prima). Comunque fino ad un certo punto mi andava internet ma non scambiavo file da PC ad HD, poi dopo aver spippolato per far passare i file da PC ad HD (cosa che ora funziona, era un problema di settaggio dell'HD) non mi va più internet.
La versione di Internet Explorer è la 9 installata proprio ieri con impostazioni di default e ho provato anche a disattivare Windows Firewall ma senza successo.
La cosa che mi fa incazzare è che in "connessioni di rete" sembra sia connesso ad internet, il percorso da PC a rete e da rete a internet è tutto ok (doppa riga verde) e se cerco nella mappatura di rete vedo a volte PC-switch-modem/router (che chiama DG834Nv2 anzichè DGN3500, come mai ???)-internet, mentre a volte vedo PC-modem/router (sempre chiamato DG834Nv2)-internet, a volte invece non vedo niente.
L'IP del router è 192.168.0.1, sul PC ho impostato di ottenre IP automatico e mi da quello che ho impostato sul modem/router per il PC (192.168.0.10). Sull'HD ho messo IP 192.168.0.10 per collegarlo al PC e Gateway (192.168.0.1).
Devo dire che se provo a mettere IP fisso sul PC (192.168.0.10) e gateway 192.168.0.1. mi dice che l'impostazione di più gateway dona alla rete l'effetto di ridondanza o una cosa simile.
Non è per caso che lui non capisce più da dove collegarsi ad internet??
Ultima cosa: se apro IE e digito http://192.168.0.1 non si apre la pagina del modem/router.
Forse si è impallato il modem/router e basta solo spengerlo e riaccenderlo. Questa cosa non ho provato a farla perchè era tardi e il modem non è fisicamente nel mio appartamento. Oggi provo.
Aiutatemi.

MItaly
26-04-2011, 21:17
Non so che impostazioni strane tu abbia messo, ma nel dubbio rifai tutto così:

Modem/router:
- indirizzo IP 192.168.0.1
- nessuna "prenotazione" DHCP
- Range DHCP: 192.168.0.50-192.168.0.127

PC:
- indirizzo IP automatico

HD:
- indirizzo IP 192.168.0.10

cantuccio
27-04-2011, 11:42
Ho rifatto il cavo a modino ed ora magicamente funziona tutto.
Ho lo switch al centro della rete collegato al PC, all'HD multimediale e al modem/router.
Il PC deve collegarsi mediante lo switch al modem/router, l'HD deve collegarsi mediante lo switch al PC (non serve che si colleghi al modem/router).
Sul modem/router (IP 192.168.0.1) ho assegnato un indirizzo IP fisso al PC (192.168.0.10).
Sul PC ho assegnato di cercare automaticamente l'IP.
Sull'HD multimediale ho messo IP 192.168.0.10, subnet mask 255.255.255.0 e default gateway 192.168.0.1

Forse non sono impostazioni corrette però funziona tutto. Scarico files da PC a HD, vedo file del PC in streaming sulla TV connessa all'HD e mi connetto ad internet dal PC.

C'è qualche controindicazione nelle mie impostazioni?

Se non ce ne sono lascio tutto così che funziona.
grazie.

MItaly
27-04-2011, 14:14
Perché l'HD multimediale e il PC hanno lo stesso IP? :confused: È sbagliatissimo...
Che range ha il DHCP sul modem/router?

cantuccio
27-04-2011, 16:49
Non sono sicuro di ciò che ho detto, non sono a casa e non ricordo bene come li ho impostati (ci ho spippolato talmente tanto ....)
Comunque il router ha indirizzi da 192.168.0.2 a 192.168.0.255.
Impostando il PC come ottieni automaticamente IP e l'HD come DHCP automatico (anzichè manuale mettendo indirizzo IP, ecc...) dovrebbe funzionare, giusto?
Ripensandoci forse ho fatto proprio così.
Poi ricontrollo e ti faccio sapere.
Grazie in ogni caso.
Una domanda devo restringere il range sul router e settare nessuna "prenotazione" DHCP ??
Come mai ??

Grazie e ciao.

Loading