PDA

Visualizza la versione completa : Problema digicom Michelangelo USB cx e Linux mint


Alpdrucken
02-05-2011, 20:47
ho seguito le tante guide su un altro forum, e soprattutto la guida del loro wiki, ma visto che il mio cd di win non aveva quel file .sys che serve per fare il cxacru-fw.bin, ho saricato direttamente il cxacru-fw.bin da internet, poi ho continuato con la guida e ho messo i dati (nome e pass) e dns nei file che indicavano ( se serve linko la guida) ma quando vado a provare a connettermi con comando pppd mi da permission denied.
ho provato sia a mettere come nome nome@dominio.it sia il nome e basta, anche se io in win uso nome@dominio.it.
non capisco dove sia il problema ho editato tutti i file che dovevo e ho seguito i comandi per mettere il cxacru-fw.bin nella cartella firmware.
che puo essere?
Ho Linux mint julia

sacarde
02-05-2011, 21:29
visto questo?

http://wiki.ubuntu-it.org/Hardware/Modem/Adsl/DigicomMichelangeloUsbCx#head-682d49e744074162e1833d479def896c3d112de0



problema simile
http://forum.ubuntu-it.org/index.php?topic=242026.0;prev_next=prev

Alpdrucken
02-05-2011, 21:59
Il primo link la guida che ho usato, il secondo non capisco cosa c'entri..

furly
02-05-2011, 22:08
Hai dato il comando pppd da root?
L'errore che ti viene restituito mi sembra c'entri con quello...
Io ho sempre utilizzato questo modem per Debian e Ubuntu e mai avuto un problema,
anche se ho utilizzato una guida diversa.

furly
02-05-2011, 22:11
Ecco la guida che ho seguito:
http://guide.debianizzati.org/index.php/Installare_i_driver_conexant_accessrunner

Lascia perdere tutta la compilazione. Tu segui da questo punto in poi:

Impostazione della connessione Prima di iniziare dovete sapere....

Funzia, vai tranquillo.

Alpdrucken
02-05-2011, 22:16
No non l'ho lanciato da root... Domani provo o se non va seguo questa guida..
Il comando sudo pppd ?

furly
02-05-2011, 22:18
Senza dubbio sudo pppd.
In ogni caso da uno sguardo anche alla guida che ho linkato.
Mai un problema.

Alpdrucken
03-05-2011, 16:18
il file resolv.conf non l'avevo in /et, l'ho creato e ho messo i valori giusti.
nella parte della guida che dice:
Inserite userid e password nei file /etc/ppp/pap-secrets e /etc/ppp/chap-secrets:

# echo "userid * password" >> /etc/ppp/pap-secrets
# echo "userid * password" >> /etc/ppp/chap-secrets
non l'ho capita: devo mettere entrambe le righe # echo "userid * password" >> /etc/ppp/pap-secrets
# echo "userid * password" >> /etc/ppp/chap-secrets
in entrambi i file o il primo per pap e il secondo per chap? e poi ci va anche il pezzo >> /etc/ppp/pap-secrets o era solo per fare capire il percorso?
se provo a dare poi il comando # pon adsl e vado a vedere il file messages dice tra le altre cose wrongpassword ma la pass dell'adsl giusta sono sicuro...

se provo a fare sudo pppd mi dice:
fra@linuxmint ~ $ sudo pppd
Plugin /usr/lib/pppd/2.4.5/pppoatm.so loaded.
PPPoATM plugin_init
PPPoATM setdevname_pppoatm - SUCCESS:8.35

sacarde
03-05-2011, 16:55
la riga:
# echo "userid * password" >> /etc/ppp/........



#
significa che devi dare il comando seguente da root


echo ....... >>
significa che inserisce la riga in fondo nel file successivo


"userid * password"
devi inserire il tuo userid e la tua password

furly
03-05-2011, 17:06
Io utilizzo Alice.
Ti posto i miei files, costruiti seguendo la guida in oggetto.

/etc/ppp/pap-secrets


* hostname "" *
guest hostname "*" -
master hostname "*" -
root hostname "*" -
support hostname "*" -
stats hostname "*" -
"aliceadsl" * "aliceadsl" *


/etc/ppp/chap-secrets


# Secrets for authentication using CHAP
# client server secret IP addresses
"aliceadsl" * "aliceadsl" *


/etc/ppp/options


lock
debug
kdebug 1
noauth
maxfail 3
ipparam ppp0
noipdefault
usepeerdns
defaultroute
noaccomp
noccp
nobsdcomp
nodeflate
nopcomp
novj
novjccomp
persist
plugin /usr/lib/pppd/2.4.5/pppoatm.so 8.35
user aliceadsl


/etc/resolv.conf


nameserver 212.216.112.112
nameserver 212.216.172.62


/etc/ppp/peer/adsl


noauth
noipdefault
usepeerdns
defaultroute
persist
plugin pppoatm.so
user "aliceadsl"


Dopo aver riavviato il sistema, in modo che venga caricato il modulo cxacru che tu
hai gi inserito in /lib/firmware/ e dando da root il comando pon adsl sei in rete.

Loading